Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1277008

Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS.

From Michael Ellerman <mpe@ellerman.id.au>
Newsgroups linux.kernel
Subject Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS.
Date 2015-11-25 05:30 +0100
Message-ID <qyzSq-16J-15@gated-at.bofh.it> (permalink)
References (1 earlier) <qwkkO-1pG-9@gated-at.bofh.it> <qwkkO-1pG-11@gated-at.bofh.it> <qwkkO-1pG-13@gated-at.bofh.it> <qy0UG-3v4-15@gated-at.bofh.it> <qy4vg-5JC-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, 2015-11-23 at 10:55 -0800, Daniel Cashman wrote:
> On 11/23/2015 07:04 AM, Will Deacon wrote:
> > On Wed, Nov 18, 2015 at 03:20:07PM -0800, Daniel Cashman wrote:
> > > +config ARCH_MMAP_RND_BITS_MAX
> > > +       default 20 if ARM64_64K_PAGES && ARCH_VA_BITS=39
> > > +       default 24 if ARCH_VA_BITS=39
> > > +       default 23 if ARM64_64K_PAGES && ARCH_VA_BITS=42
> > > +       default 27 if ARCH_VA_BITS=42
> > > +       default 29 if ARM64_64K_PAGES && ARCH_VA_BITS=48
> > > +       default 33 if ARCH_VA_BITS=48
> > > +       default 15 if ARM64_64K_PAGES
> > > +       default 19
> > > +
> > > +config ARCH_MMAP_RND_COMPAT_BITS_MIN
> > > +       default 7 if ARM64_64K_PAGES
> > > +       default 11
> > 
> > FYI: we now support 16k pages too, so this might need updating. It would
> > be much nicer if this was somehow computed rather than have the results
> > all open-coded like this.
> 
> Yes, I ideally wanted this to be calculated based on the different page
> options and VA_BITS (which itself has a similar stanza), but I don't
> know how to do that/if it is currently supported in Kconfig. This would
> be even more desirable with the addition of 16K_PAGES, as with this
> setup we have a combinatorial problem.
> 
> We could move this logic into the code where min/max are initialized,
> but that would create its own mess, creating new Kconfig values to
> introduce it in an arch-agnostic way after patch-set v2 moved that to
> mm/mmap.c instead of arch/${arch}/mm/mmap.c Suggestions welcome.


Could we instead change the meaning of the mmap_rnd_bits value to be the number
of address space bits that may be randomised?

ie. 40 would mean "please randomise in a 1T range", which with PAGE_SIZE=4K
gives you 28 random bits. etc.

That would make the value independent of PAGE_SIZE, and only depend on the size
of the address space.

It would also mean the values userspace sets and sees don't need to change if the
kernel PAGE_SIZE changes. (which probably doesn't happen often but still)

cheers

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v3 2/4] arm: mm: support ARCH_MMAP_RND_BITS. Daniel Cashman <dcashman@android.com> - 2015-11-19 00:30 +0100
  [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Daniel Cashman <dcashman@android.com> - 2015-11-19 00:30 +0100
    Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Will Deacon <will.deacon@arm.com> - 2015-11-23 16:10 +0100
      Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Daniel Cashman <dcashman@android.com> - 2015-11-23 20:00 +0100
        Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Michael Ellerman <mpe@ellerman.id.au> - 2015-11-25 05:30 +0100
          Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Daniel Cashman <dcashman@android.com> - 2015-11-25 20:40 +0100
        Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Catalin Marinas <catalin.marinas@arm.com> - 2015-11-25 13:10 +0100
          Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Daniel Cashman <dcashman@android.com> - 2015-11-25 21:40 +0100
            Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Andrey Ryabinin <ryabinin.a.a@gmail.com> - 2015-11-27 09:40 +0100
              Re: [PATCH v3 3/4] arm64: mm: support ARCH_MMAP_RND_BITS. Catalin Marinas <catalin.marinas@arm.com> - 2015-11-27 10:40 +0100

csiph-web