Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1275880
| From | Rasmus Villemoes <linux@rasmusvillemoes.dk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] fs/file.c: __const_max is actually __const_min :-) |
| Date | 2015-11-23 22:40 +0100 |
| Message-ID | <qy707-7p3-37@gated-at.bofh.it> (permalink) |
| References | <qoTfH-7Sg-1@gated-at.bofh.it> <qoTpo-7W4-9@gated-at.bofh.it> |
| Organization | D03 |
On Thu, Oct 29 2015, Albino B Neto <bino@bino.us> wrote: > 2015-10-29 9:01 GMT-02:00 Rasmus Villemoes <linux@rasmusvillemoes.dk>: >> 7f4b36f9bb930 "get rid of files_defer_init()" inexplicably changed a >> min() to a __const_max() - but the __const_max macro actually gives >> the minimum... So no functional change, just less confusing naming. >> >> Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk> >> --- >> fs/file.c | 6 +++--- >> 1 file changed, 3 insertions(+), 3 deletions(-) >> >> diff --git a/fs/file.c b/fs/file.c >> index 6c672ad329e9..b2d74f6001eb 100644 >> --- a/fs/file.c >> +++ b/fs/file.c >> @@ -25,9 +25,9 @@ >> >> int sysctl_nr_open __read_mostly = 1024*1024; >> int sysctl_nr_open_min = BITS_PER_LONG; >> -/* our max() is unusable in constant expressions ;-/ */ >> -#define __const_max(x, y) ((x) < (y) ? (x) : (y)) >> -int sysctl_nr_open_max = __const_max(INT_MAX, ~(size_t)0/sizeof(void *)) & >> +/* our min() is unusable in constant expressions ;-/ */ >> +#define __const_min(x, y) ((x) < (y) ? (x) : (y)) >> +int sysctl_nr_open_max = __const_min(INT_MAX, ~(size_t)0/sizeof(void *)) & >> -BITS_PER_LONG; >> >> static void *alloc_fdmem(size_t size) > > Confused code or no ? The code is fine, the macro name sucks. Al, ping? -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH] fs/file.c: __const_max is actually __const_min :-) Rasmus Villemoes <linux@rasmusvillemoes.dk> - 2015-11-23 22:40 +0100
csiph-web