Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1275108
| From | Yuyang Du <yuyang.du@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 0/6] sched/fair: Clean up sched metric definitions |
| Date | 2015-11-23 09:20 +0100 |
| Message-ID | <qxUvV-7DO-23@gated-at.bofh.it> (permalink) |
| References | <qmikh-3B6-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Peter and Ingo, A reminder of this patch searies, in case you forget. Thanks, Yuyang On Thu, Oct 22, 2015 at 07:24:42AM +0800, Yuyang Du wrote: > Hi Peter and Ingo, > > As discussed recently, the sched metrics need a little bit cleanup. This > series of patches attempt to do that: refactor, rename, remove... > > Thanks a lot to Ben, Morten, Dietmar, Vincent, and others who provided > valuable comments. > > v2 changes: > - Rename SCHED_RESOLUTION_SHIFT to SCHED_FIXEDPOINT_SHIFT, thanks to Peter > - Fix bugs in calculate_imbalance(), thanks to Vincent > - Fix "#if 0" for increased kernel load > > Thanks, > Yuyang > > Yuyang Du (6): > sched/fair: Generalize the load/util averages resolution definition > sched/fair: Remove SCHED_LOAD_SHIFT and SCHED_LOAD_SCALE > sched/fair: Add introduction to the sched load avg metrics > sched/fair: Remove scale_load_down() for load_avg > sched/fair: Rename scale_load() and scale_load_down() > sched/fair: Remove unconditionally inactive code > > include/linux/sched.h | 81 +++++++++++++++++++++++++++++++++++++++++++-------- > init/Kconfig | 16 ++++++++++ > kernel/sched/core.c | 8 ++--- > kernel/sched/fair.c | 33 ++++++++++----------- > kernel/sched/sched.h | 52 +++++++++++++++------------------ > 5 files changed, 127 insertions(+), 63 deletions(-) > > -- > 2.1.4 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH v2 0/6] sched/fair: Clean up sched metric definitions Yuyang Du <yuyang.du@intel.com> - 2015-11-23 09:20 +0100
csiph-web