Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1271444
| From | Jerry Hoemann <jerry.hoemann@hpe.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls |
| Date | 2015-11-17 18:00 +0100 |
| Message-ID | <qvRLQ-7AN-17@gated-at.bofh.it> (permalink) |
| References | <qvwR3-2pG-15@gated-at.bofh.it> <qvxk6-2PK-3@gated-at.bofh.it> <qvzlU-48E-21@gated-at.bofh.it> <qvDfP-6Ck-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Nov 16, 2015 at 05:29:41PM -0800, Dan Williams wrote: > On Mon, Nov 16, 2015 at 1:10 PM, Jerry Hoemann <jerry.hoemann@hpe.com> wrote: > > On Mon, Nov 16, 2015 at 11:00:20AM -0800, Dan Williams wrote: > >> On Mon, Nov 16, 2015 at 10:38 AM, Jerry Hoemann <jerry.hoemann@hpe.com> wrote: > >> > > >> ... > >> Let's not do the _intel vs _passthru split. I want to convert the > >> existing commands over to this new interface and deprecate the old > >> ioctl-command formats. I.e. it isn't the case that this will be a > >> always be a blind "passthru" mechanism, the kernel will need to crack > >> open this payload in some circumstances. > > > > > > I'm confused. > > > > In this version there is only 1 ioctl 'N'. The pass thru is using > > number 100. This is what I thought you wanted from prior comments. > > It is indeed, I like that change. > > > The split are for internal functions that deal specifically w/ > > the argument marshaling code and copy-in/copy-out. These mechanisms > > are different. > > > > I understand that you want to switch over, but don't you (at least for > > the time being) need to keep the old marshaling code for the current > > use case? I was assuming a sequence like: > > 1. The pass thru code gets submitted. > > 2. The current tools are converted over to using the pass thru, > > 3. The marshaling code using nd_cmd_in_size etc., would then > > be removed. > > > > Are you wanting to make one big change and not in separate steps? > > I want to do it in separate steps, I'd just like to see cmd number 100 > added to the existing __nd_ioctl and acpi_nfit_ctl routines. That Why? > plus quibbling about the name "ND_CMD_PASSTHRU". Given the plans to > eventually replace the existing commands we can call it something like > 'ND_DSM_GENERIC'. No problem. I'll change the name for ndn_passthru_pkg in a similar fashion. Question: Are you planning to add other CMDs to the IOCTL in the future? (eg. ones not directly related to calling _dsm?) Or, is the ultimate goal to have an IOCTL that supports only the generic DSM call? -- ----------------------------------------------------------------------------- Jerry Hoemann Software Engineer Hewlett-Packard Enterprise ----------------------------------------------------------------------------- -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-16 19:40 +0100
[PATCH v2 1/3] nvdimm: Clean-up access mode check. Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-16 19:40 +0100
[PATCH v2 3/3] nvdimm: Add IOCTL pass thru functions Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-16 19:40 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Dan Williams <dan.j.williams@intel.com> - 2015-11-16 20:10 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-16 22:20 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Dan Williams <dan.j.williams@intel.com> - 2015-11-17 02:30 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-17 18:00 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Dan Williams <dan.j.williams@intel.com> - 2015-11-17 18:10 +0100
Re: [PATCH v2 0/3] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann <jerry.hoemann@hpe.com> - 2015-11-18 08:10 +0100
csiph-web