Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1270952
| From | Boris Brezillon <boris.brezillon@free-electrons.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 18/27] mtd: nand: update mtd_to_nand() |
| Date | 2015-11-17 09:30 +0100 |
| Message-ID | <qvJOi-2w8-29@gated-at.bofh.it> (permalink) |
| References | <qvsaK-7Us-5@gated-at.bofh.it> <qvskr-7Yr-57@gated-at.bofh.it> <qvEOD-7G2-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, 16 Nov 2015 19:03:53 -0800
Brian Norris <computersforpeace@gmail.com> wrote:
> On Mon, Nov 16, 2015 at 02:37:51PM +0100, Boris Brezillon wrote:
> > Now that all drivers are using the mtd instance embedded in the nand_chip
>
> Do you have a script that verifies this? I thought you did at some
> point, and it'd be nice to note it, so I can also use it to verify
> things once it gets applied.
No, didn't write that script, but it should probably look like the one
I used to remove the mtd field from driver private struct.
>
> > struct we can safely update the mtd_to_nand_chip() implementation to use
>
> Nit: s/mtd_to_nand_chip/mtd_to_nand/
Yep, I'll fix that.
>
> > the container_of macro instead of returning the content of mtd->priv.
> > This will allow us to remove mtd->priv = chip assignments done in all
> > NAND controller drivers.
> >
> > Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
> > ---
> > include/linux/mtd/nand.h | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/include/linux/mtd/nand.h b/include/linux/mtd/nand.h
> > index 8ec071e..873646d 100644
> > --- a/include/linux/mtd/nand.h
> > +++ b/include/linux/mtd/nand.h
> > @@ -734,7 +734,7 @@ static inline struct device_node *nand_get_flash_node(struct nand_chip *chip)
> >
> > static inline struct nand_chip *mtd_to_nand(struct mtd_info *mtd)
> > {
> > - return mtd->priv;
> > + return container_of(mtd, struct nand_chip, mtd);
> > }
> >
> > static inline struct mtd_info *nand_to_mtd(struct nand_chip *chip)
> > --
> > 2.1.4
> >
--
Boris Brezillon, Free Electrons
Embedded Linux and Kernel engineering
http://free-electrons.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 18/27] mtd: nand: update mtd_to_nand() Boris Brezillon <boris.brezillon@free-electrons.com> - 2015-11-16 14:50 +0100
Re: [PATCH 18/27] mtd: nand: update mtd_to_nand() Brian Norris <computersforpeace@gmail.com> - 2015-11-17 04:10 +0100
Re: [PATCH 18/27] mtd: nand: update mtd_to_nand() Boris Brezillon <boris.brezillon@free-electrons.com> - 2015-11-17 09:30 +0100
csiph-web