Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1268073
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 |
| Date | 2015-11-12 17:20 +0100 |
| Message-ID | <qu2Lo-2J4-33@gated-at.bofh.it> (permalink) |
| References | <qtGUy-5jq-13@gated-at.bofh.it> <qtGUA-5jq-51@gated-at.bofh.it> <qu28F-2eq-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thursday 12 November 2015 10:30:23 Boris Ostrovsky wrote: > > diff --git a/arch/x86/xen/time.c b/arch/x86/xen/time.c > > index 663c2ea..3bbd377 100644 > > --- a/arch/x86/xen/time.c > > +++ b/arch/x86/xen/time.c > > @@ -134,10 +134,10 @@ static int xen_pvclock_gtod_notify(struct notifier_block *nb, > > if (!was_set && timespec_compare(&now, &next_sync) < 0) > > return NOTIFY_OK; > > > > - op.cmd = XENPF_settime; > > - op.u.settime.secs = now.tv_sec; > > - op.u.settime.nsecs = now.tv_nsec; > > - op.u.settime.system_time = xen_clocksource_read(); > > + op.cmd = XENPF_settime32; > > + op.u.settime32.secs = now.tv_sec; > > + op.u.settime32.nsecs = now.tv_nsec; > > + op.u.settime32.system_time = xen_clocksource_read(); > > Can/should we switch to time64 here? (This would require a couple more > changes but they would all be local to this routine). We definitely should. We are in the process of removing all uses of timespec from the kernel in favor of timespec64, and this requires changing the Xen code as well if we want to do it right. I suppose that both Dom0 and DomU will have to support the old and the new interface for x86, so we have a fallback if the 64-bit interface fails. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v3 0/6] Xen wallclock on arm and arm64 Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
[PATCH v3 5/6] xen/arm: introduce xen_read_wallclock Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
Re: [PATCH v3 5/6] xen/arm: introduce xen_read_wallclock Arnd Bergmann <arnd@arndb.de> - 2015-11-11 21:40 +0100
Re: [PATCH v3 5/6] xen/arm: introduce xen_read_wallclock Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-12 12:30 +0100
[PATCH v3 2/6] xen/arm: introduce HYPERVISOR_platform_op on arm and arm64 Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
[PATCH v3 6/6] xen/arm: set the system time in Xen via the XENPF_settime64 hypercall Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
Re: [PATCH v3 6/6] xen/arm: set the system time in Xen via the XENPF_settime64 hypercall Arnd Bergmann <arnd@arndb.de> - 2015-11-11 21:40 +0100
[PATCH v3 4/6] arm: extend pvclock_wall_clock with sec_hi Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
[PATCH v3 1/6] xen: rename dom0_op to platform_op Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
Re: [PATCH v3 1/6] xen: rename dom0_op to platform_op Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-12 16:10 +0100
Re: [PATCH v3 1/6] xen: rename dom0_op to platform_op Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2015-11-12 16:30 +0100
[PATCH v3 3/6] xen: introduce XENPF_settime64 Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-11 18:00 +0100
Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2015-11-12 16:40 +0100
Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 Arnd Bergmann <arnd@arndb.de> - 2015-11-12 17:20 +0100
Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 Stefano Stabellini <stefano.stabellini@eu.citrix.com> - 2015-11-12 17:40 +0100
Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2015-11-12 18:20 +0100
Re: [PATCH v3 3/6] xen: introduce XENPF_settime64 Arnd Bergmann <arnd@arndb.de> - 2015-11-12 20:30 +0100
csiph-web