Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1267608

Re: [UNTESTED PATCH] x86, mce: Avoid double entry of deferred errors into the genpool.

From "Chen, Gong" <gong.chen@linux.intel.com>
Newsgroups linux.kernel
Subject Re: [UNTESTED PATCH] x86, mce: Avoid double entry of deferred errors into the genpool.
Date 2015-11-12 05:30 +0100
Message-ID <qtRGh-44q-9@gated-at.bofh.it> (permalink)
References <qtJpo-71V-17@gated-at.bofh.it> <qtM3W-lk-77@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

On Wed, Nov 11, 2015 at 02:01:51PM -0800, Luck, Tony wrote:
> Date: Wed, 11 Nov 2015 14:01:51 -0800
> From: Tony Luck <tony.luck@intel.com>
> To: "Chen, Gong" <gong.chen@linux.intel.com>
> Cc: bp@alien8.de, linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org
> Subject: [UNTESTED PATCH] x86, mce: Avoid double entry of deferred errors
>  into the genpool.
> 
> We used to have a special ring buffer for deferred errors that
> was used to mark problem pages. We replaced that with a genpool.
> Then later converted mce_log() to also use the same genpool. As
> a result we end up adding all deferred errors to the genpool twice.
> 
> Rearrange this code. Make sure to set the m.severity and m.usable_addr
> fields for deferred errors. Then if flags and mca_cfg.dont_log_ce mean
> we call mce_log() we are done, because that will add this entry to the
> genpool.
> 
> If we skipped mce_log(), then we still want to take action for the
> deferred error, so add to the genpool.
> 
> Changed the name of the boolean "error_logged" to "error_seen", we
> should set it whether of not we logged an error because the return
> value from machine_check_poll() is used to decide whether storms
> have subsided or not.
> 
> Reported-by: Chen, Gong <gong.chen.linux.intel.com>
> Signed-off-by: Tony Luck <tony.luck@intel.com>
> ---

It's much better than my original version.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] Cleanup useless codes in CMCI handler "Chen, Gong" <gong.chen@linux.intel.com> - 2015-11-11 04:30 +0100
  Re: [PATCH] Cleanup useless codes in CMCI handler "Luck, Tony" <tony.luck@intel.com> - 2015-11-11 20:40 +0100
    [UNTESTED PATCH] x86, mce: Avoid double entry of deferred errors into the genpool. Tony Luck <tony.luck@intel.com> - 2015-11-11 23:30 +0100
      Re: [UNTESTED PATCH] x86, mce: Avoid double entry of deferred errors  into the genpool. "Chen, Gong" <gong.chen@linux.intel.com> - 2015-11-12 05:30 +0100

csiph-web