Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1264836
| From | Wolfram Sang <wsa@the-dreams.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API |
| Date | 2015-11-07 14:40 +0100 |
| Message-ID | <qsbSN-2TM-3@gated-at.bofh.it> (permalink) |
| References | <qqqjf-7AX-7@gated-at.bofh.it> <qqqjf-7AX-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
On Mon, Nov 02, 2015 at 04:36:13PM +0000, Phil Edworthy wrote: > The main purpose of this change is to avoid calling pci_ioremap_io() as > this is not available on arm64. However, instead of doing the range passing > in this driver we can utilise of_pci_get_host_bridge_resources(). > > This is similar to changes made to the generic PCI host driver in commit > dbf9826d "PCI: generic: Convert to DT resource parsing API". > > Signed-off-by: Phil Edworthy <phil.edworthy@renesas.com> Reported-by: Wolfram Sang <wsa+renesas@sang-engineering.com> Tested-by: Wolfram Sang <wsa+renesas@sang-engineering.com> Works for me and my USB3 card. I also like going the global io_offset variable away and the code readability improved, too, IMO. One question: > + case IORESOURCE_MEM: > + parent = &iomem_resource; > + res_valid |= !(res->flags & IORESOURCE_PREFETCH); > + break; res_valid doesn't seem to be actually used?
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API Phil Edworthy <phil.edworthy@renesas.com> - 2015-11-02 17:40 +0100
Re: [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API Wolfram Sang <wsa@the-dreams.de> - 2015-11-07 14:40 +0100
RE: [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API Phil Edworthy <phil.edworthy@renesas.com> - 2015-11-09 10:40 +0100
csiph-web