Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1263573

Re: [PATCH] decnet: remove macro-local declarations

From Joe Perches <joe@perches.com>
Newsgroups linux.kernel
Subject Re: [PATCH] decnet: remove macro-local declarations
Date 2015-11-05 23:10 +0100
Message-ID <qrATh-44X-15@gated-at.bofh.it> (permalink)
References <qrpXQ-5kx-31@gated-at.bofh.it> <qryoq-2og-23@gated-at.bofh.it> <qryy6-2rw-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, 2015-11-05 at 20:38 +0100, Julia Lawall wrote:
> On Thu, 5 Nov 2015, David Miller wrote:
> > From: Julia Lawall <Julia.Lawall@lip6.fr>
> > Date: Thu,  5 Nov 2015 11:18:16 +0100> 
> > > Move the variable declarations from the for_nexthops macro to the
> > > surrounding context, so that it is clear where these variables are
> > > declared.  This also makes it possible to remove the endfor_nexthops macro.
> > > 
> > > This change adds new arguments to the macro for_nexthops.  They are ordered
> > > such that a pointer to the referenced object comes first, the index in the
> > > list comes next, and the list itself comes last, roughly in analogy with
> > > the list_for_each macros.
[]
> > > This patch takes care of a single file, where the macros are defined
> > > locally.  If the basic transformation looks OK, I will change the other
> > > files that either likewise define their own macros or use the macros in
> > > net/mpls/internal.h.  The potentially affected files are:
> >  ...
> > 
> > This looks fine to me.
> > 
> > Please resubmit this when net-next opens back up, which should be
> > shortly after -rc1.
> 
> OK, I'll do the others then too.

If you do can you please parenthesize the macro arguments?

#define for_nexthops(nh, nhsel, fi) \
 	for (nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; (nh)++, (nhsel)++)
instead of
	for(nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; nh++, nhsel++)

And perhaps a renaming might be better

	s/for_nexthops/for_each_nexthop/
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] decnet: remove macro-local declarations Julia Lawall <Julia.Lawall@lip6.fr> - 2015-11-05 11:30 +0100
  Re: [PATCH] decnet: remove macro-local declarations David Miller <davem@davemloft.net> - 2015-11-05 20:30 +0100
    Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-05 20:40 +0100
      Re: [PATCH] decnet: remove macro-local declarations Joe Perches <joe@perches.com> - 2015-11-05 23:10 +0100
        Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-05 23:30 +0100
    Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-05 21:10 +0100
      Re: [PATCH] decnet: remove macro-local declarations David Miller <davem@davemloft.net> - 2015-11-05 21:20 +0100
        Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-06 12:00 +0100
          Re: [PATCH] decnet: remove macro-local declarations walter harms <wharms@bfs.de> - 2015-11-06 12:50 +0100
            Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-06 12:50 +0100
          Re: [PATCH] decnet: remove macro-local declarations David Miller <davem@davemloft.net> - 2015-11-07 19:20 +0100
            Re: [PATCH] decnet: remove macro-local declarations Julia Lawall <julia.lawall@lip6.fr> - 2015-11-07 19:30 +0100

csiph-web