Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1261106
| From | Minchan Kim <minchan@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 6/8] mm: lru_deactivate_fn should clear PG_referenced |
| Date | 2015-11-03 02:20 +0100 |
| Message-ID | <qqyqu-4js-7@gated-at.bofh.it> (permalink) |
| References | <qpbYZ-2NI-5@gated-at.bofh.it> <qpbZ0-2NI-29@gated-at.bofh.it> <qphi2-5Rm-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Oct 30, 2015 at 01:47:11PM +0100, Michal Hocko wrote: > On Fri 30-10-15 16:01:42, Minchan Kim wrote: > > deactivate_page aims for accelerate for reclaiming through > > moving pages from active list to inactive list so we should > > clear PG_referenced for the goal. > > I might be missing something but aren't we using PG_referenced only for > pagecache (and shmem) pages? You don't miss anything. For pages which are candidate of MADV_FREEing( ie, normal anonymous page, not shmem, tmpfs), they shouldn't have any PG_referenced. Although normal anonymous pages have it, VM doesn't respect it. One thing I suspect is GUP with FOLL_TOUCH which calls mark_page_accesssed on anonymous page and will mark PG_referenced. Technically, it's not a problem but just want to notice in this time. Primary reason was I want to make deactivate_page *general* so it could be used for file page as well as anon pages in future. But at the moment, user of deactivate_page is only MADV_FREE so it might be better to merge the logic for anon page deactivation into deactivate_file_page and rename it as general "deactivate_page" if you're thinking it's better. > > > > > Acked-by: Hugh Dickins <hughd@google.com> > > Suggested-by: Andrew Morton <akpm@linux-foundation.org> > > Signed-off-by: Minchan Kim <minchan@kernel.org> > > --- > > mm/swap.c | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/mm/swap.c b/mm/swap.c > > index d0eacc5f62a3..4a6aec976ab1 100644 > > --- a/mm/swap.c > > +++ b/mm/swap.c > > @@ -810,6 +810,7 @@ static void lru_deactivate_fn(struct page *page, struct lruvec *lruvec, > > > > del_page_from_lru_list(page, lruvec, lru + LRU_ACTIVE); > > ClearPageActive(page); > > + ClearPageReferenced(page); > > add_page_to_lru_list(page, lruvec, lru); > > > > __count_vm_event(PGDEACTIVATE); > > -- > > 1.9.1 > > -- > Michal Hocko > SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 6/8] mm: lru_deactivate_fn should clear PG_referenced Minchan Kim <minchan@kernel.org> - 2015-11-03 02:20 +0100 Re: [PATCH 6/8] mm: lru_deactivate_fn should clear PG_referenced Michal Hocko <mhocko@kernel.org> - 2015-11-04 09:30 +0100
csiph-web