Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1260698

Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with kvm_set_msi_inatomic

From Radim Krcmar <rkrcmar@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with kvm_set_msi_inatomic
Date 2015-11-02 16:00 +0100
Message-ID <qqoKu-6yI-15@gated-at.bofh.it> (permalink)
References <qqmpk-5gc-17@gated-at.bofh.it> <qqmpk-5gc-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2015-11-02 13:21+0100, Paolo Bonzini:
> We do not want to do too much work in atomic context, in particular
> not walking all the VCPUs of the virtual machine.  So we want
> to distinguish the architecture-specific injection function for irqfd
> from kvm_set_msi.  Since it's still empty, reuse the newly added
> kvm_arch_set_irq and rename it to kvm_arch_set_irq_inatomic.

kvm/queue uses kvm_arch_set_irq since b7184313f4b9 ("kvm/x86: Hyper-V
synthetic interrupt controller").

Is synic going to be dropped before this patch is merged?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with kvm_set_msi_inatomic Paolo Bonzini <pbonzini@redhat.com> - 2015-11-02 13:30 +0100
  Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with  kvm_set_msi_inatomic Radim Krcmar <rkrcmar@redhat.com> - 2015-11-02 16:00 +0100
    Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with  kvm_set_msi_inatomic Paolo Bonzini <pbonzini@redhat.com> - 2015-11-02 17:10 +0100
      Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with  kvm_set_msi_inatomic Radim Krcmar <rkrcmar@redhat.com> - 2015-11-02 18:10 +0100
        Re: [PATCH 1/3] KVM: x86: merge kvm_arch_set_irq with  kvm_set_msi_inatomic Paolo Bonzini <pbonzini@redhat.com> - 2015-11-02 18:10 +0100

csiph-web