Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1260205
| From | David Miller <davem@davemloft.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] VSOCK: define VSOCK_SS_LISTEN once only |
| Date | 2015-11-01 18:20 +0100 |
| Message-ID | <qq4sp-2K7-13@gated-at.bofh.it> (permalink) |
| References | <qoU26-89o-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Stefan Hajnoczi <stefanha@redhat.com> Date: Thu, 29 Oct 2015 11:57:42 +0000 > The SS_LISTEN socket state is defined by both af_vsock.c and > vmci_transport.c. This is risky since the value could be changed in one > file and the other would be out of sync. > > Rename from SS_LISTEN to VSOCK_SS_LISTEN since the constant is not part > of enum socket_state (SS_CONNECTED, ...). This way it is clear that the > constant is vsock-specific. > > The big text reflow in af_vsock.c was necessary to keep to the maximum > line length. Text is unchanged except for s/SS_LISTEN/VSOCK_SS_LISTEN/. > > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com> Applied to net-next, thanks. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] VSOCK: define VSOCK_SS_LISTEN once only Stefan Hajnoczi <stefanha@redhat.com> - 2015-10-29 13:00 +0100 Re: [PATCH] VSOCK: define VSOCK_SS_LISTEN once only David Miller <davem@davemloft.net> - 2015-11-01 18:20 +0100
csiph-web