Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1259609
| From | John Garry <john.garry@huawei.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support |
| Date | 2015-10-30 17:30 +0100 |
| Message-ID | <qpkIX-84i-19@gated-at.bofh.it> (permalink) |
| References | <qnQDf-Nh-11@gated-at.bofh.it> <qnQDf-Nh-13@gated-at.bofh.it> <qpinN-6tx-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 30/10/2015 13:53, Arnd Bergmann wrote:
> On Monday 26 October 2015 22:14:58 John Garry wrote:
>
>> + /*
>> + * DMA-map SMP request, response buffers
>> + */
>> + /* req */
>> + sg_req = &task->smp_task.smp_req;
>> + elem = dma_map_sg(dev, sg_req, 1, DMA_TO_DEVICE);
>> + if (!elem)
>> + return -ENOMEM;
>> + req_len = sg_dma_len(sg_req);
>> + req_dma_addr = sg_dma_address(sg_req);
>
> If you only use the first element, could you just use dma_map_single()?
>
Can do. Actually sg_req seems only ever has one element:
expander.c, smp_execute_task()
sg_init_one(&task->smp_task.smp_req, req, req_size);
>> + hdr->cmd_table_addr_lo = cpu_to_le32(lower_32_bits(req_dma_addr));
>> + hdr->cmd_table_addr_hi = cpu_to_le32(upper_32_bits(req_dma_addr));
>> +
>> + hdr->sts_buffer_addr_lo =
>> + cpu_to_le32(lower_32_bits(slot->status_buffer_dma));
>> + hdr->sts_buffer_addr_hi =
>> + cpu_to_le32(upper_32_bits(slot->status_buffer_dma));
>> +
>>
>
> I see these a lot in your code. Could you replace this wit
>
> hdr->cmd_table_addr = cpu_to_le64(req_dma_addr);
>
This seems reasonable. They are not swapped.
> and so on? That would be much more readable. Or are the two __le32 variables
> swapped? If so, you could add a small helper function like
>
> static inline __le64 cpu_to_le64_wordswapped(u64 val)
> {
> return cpu_to_le64(val >> 32 | val << 32);
> }
>
> Arnd
>
> .
>
cheers
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 27/32] scsi: hisi_sas: add smp protocol support John Garry <john.garry@huawei.com> - 2015-10-26 15:10 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support Arnd Bergmann <arnd@arndb.de> - 2015-10-30 15:00 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support John Garry <john.garry@huawei.com> - 2015-10-30 17:30 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support John Garry <john.garry@huawei.com> - 2015-11-02 18:10 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support Arnd Bergmann <arnd@arndb.de> - 2015-11-02 21:40 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support John Garry <john.garry@huawei.com> - 2015-11-03 12:50 +0100
Re: [PATCH v2 27/32] scsi: hisi_sas: add smp protocol support Arnd Bergmann <arnd@arndb.de> - 2015-11-03 13:40 +0100
csiph-web