Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1254826
| From | Greg Kroah-Hartman <gregkh@linuxfoundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 3.14 00/25] 3.14.56-stable review |
| Date | 2015-10-23 20:20 +0200 |
| Message-ID | <qmONc-d5-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
This is the start of the stable review cycle for the 3.14.56 release.
There are 25 patches in this series, all will be posted as a response
to this one. If anyone has any issues with these being applied, please
let me know.
Responses should be made by Sun Oct 25 17:45:45 UTC 2015.
Anything received after that time might be too late.
The whole patch series can be found in one patch at:
kernel.org/pub/linux/kernel/v3.x/stable-review/patch-3.14.56-rc1.gz
and the diffstat can be found below.
thanks,
greg k-h
-------------
Pseudo-Shortlog of commits:
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Linux 3.14.56-rc1
Konstantin Khlebnikov <khlebnikov@yandex-team.ru>
sched/preempt: Fix cond_resched_lock() and cond_resched_softirq()
Frederic Weisbecker <fweisbec@gmail.com>
sched/preempt: Rename PREEMPT_CHECK_OFFSET to PREEMPT_DISABLE_OFFSET
Ilya Dryomov <idryomov@gmail.com>
rbd: fix double free on rbd_dev->header_name
Mike Snitzer <snitzer@redhat.com>
dm thin: fix missing pool reference count decrement in pool_ctr error path
Alex Deucher <alexander.deucher@amd.com>
drm/radeon: add pm sysfs files late
Ben Skeggs <bskeggs@redhat.com>
drm/nouveau/fbcon: take runpm reference when userspace has an open fd
Shaohua Li <shli@fb.com>
workqueue: make sure delayed work run in local cpu
Mika Westerberg <mika.westerberg@linux.intel.com>
i2c: designware: Do not use parameters from ACPI on Dell Inspiron 7348
Wolfram Sang <wsa+renesas@sang-engineering.com>
i2c: s3c2410: enable RuntimePM before registering to the core
Wolfram Sang <wsa+renesas@sang-engineering.com>
i2c: rcar: enable RuntimePM before registering to the core
Will Deacon <will.deacon@arm.com>
arm64: errata: use KBUILD_CFLAGS_MODULE for erratum #843419
Chris Mason <clm@fb.com>
btrfs: fix use after free iterating extrefs
Russell King <rmk+kernel@arm.linux.org.uk>
crypto: ahash - ensure statesize is non-zero
Dave Kleikamp <dave.kleikamp@oracle.com>
crypto: sparc - initialize blkcipher.ivsize
Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
asix: Do full reset during ax88772_bind
Michel Stam <m.stam@fugro.nl>
asix: Don't reset PHY on if_up for ASIX 88772
Joe Perches <joe@perches.com>
ethtool: Use kcalloc instead of kmalloc for ethtool_get_strings
Guillaume Nault <g.nault@alphalink.fr>
ppp: don't override sk->sk_state in pppoe_flush_dev()
Eric Dumazet <edumazet@google.com>
net: add pfmemalloc check in sk_add_backlog()
Pravin B Shelar <pshelar@nicira.com>
skbuff: Fix skb checksum partial check.
Pravin B Shelar <pshelar@nicira.com>
skbuff: Fix skb checksum flag on skb pull
Andrey Vagin <avagin@openvz.org>
net/unix: fix logic about sk_peek_offset
Aaron Conole <aconole@bytheb.org>
af_unix: return data from multiple SKBs on recv() with MSG_PEEK flag
Aaron Conole <aconole@bytheb.org>
af_unix: Convert the unix_sk macro to an inline function for type safety
Alexander Couzens <lynxis@fe80.eu>
l2tp: protect tunnel->del_work by ref_count
-------------
Diffstat:
Makefile | 4 +-
arch/arm64/Makefile | 2 +-
arch/sparc/crypto/aes_glue.c | 2 +
arch/sparc/crypto/camellia_glue.c | 1 +
arch/sparc/crypto/des_glue.c | 2 +
arch/x86/include/asm/preempt.h | 4 +-
crypto/ahash.c | 3 +-
drivers/block/rbd.c | 1 -
drivers/gpu/drm/nouveau/nouveau_fbcon.c | 24 +++++++++++
drivers/gpu/drm/radeon/radeon_display.c | 14 +------
drivers/gpu/drm/radeon/radeon_pm.c | 63 +++++++++++++++++------------
drivers/i2c/busses/i2c-designware-platdrv.c | 20 +++++++++
drivers/i2c/busses/i2c-rcar.c | 7 ++--
drivers/i2c/busses/i2c-s3c2410.c | 8 ++--
drivers/md/dm-thin.c | 2 +-
drivers/net/ppp/pppoe.c | 1 -
drivers/net/usb/asix_devices.c | 16 +-------
fs/btrfs/backref.c | 8 ++--
include/asm-generic/preempt.h | 5 ++-
include/linux/preempt.h | 5 ++-
include/linux/preempt_mask.h | 16 ++++++--
include/linux/sched.h | 6 ---
include/linux/skbuff.h | 3 ++
include/net/af_unix.h | 6 ++-
include/net/sock.h | 8 ++++
kernel/sched/core.c | 6 +--
kernel/workqueue.c | 8 ++--
net/core/ethtool.c | 2 +-
net/core/skbuff.c | 9 +++--
net/l2tp/l2tp_core.c | 11 ++++-
net/unix/af_unix.c | 16 +++++++-
31 files changed, 182 insertions(+), 101 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 3.14 00/25] 3.14.56-stable review Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 02/25] af_unix: Convert the unix_sk macro to an inline function for type safety Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 24/25] sched/preempt: Rename PREEMPT_CHECK_OFFSET to PREEMPT_DISABLE_OFFSET Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 14/25] btrfs: fix use after free iterating extrefs Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 06/25] skbuff: Fix skb checksum partial check. Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 15/25] arm64: errata: use KBUILD_CFLAGS_MODULE for erratum #843419 Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 16/25] i2c: rcar: enable RuntimePM before registering to the core Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 25/25] sched/preempt: Fix cond_resched_lock() and cond_resched_softirq() Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 05/25] skbuff: Fix skb checksum flag on skb pull Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 [PATCH 3.14 09/25] ethtool: Use kcalloc instead of kmalloc for ethtool_get_strings Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-10-23 20:20 +0200 Re: [PATCH 3.14 00/25] 3.14.56-stable review Shuah Khan <shuahkh@osg.samsung.com> - 2015-10-23 23:10 +0200 Re: [PATCH 3.14 00/25] 3.14.56-stable review Guenter Roeck <linux@roeck-us.net> - 2015-10-24 04:10 +0200
csiph-web