Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1249170

Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning

From Arnd Bergmann <arnd@arndb.de>
Newsgroups linux.kernel
Subject Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning
Date 2015-10-16 23:50 +0200
Message-ID <qkl2W-24I-13@gated-at.bofh.it> (permalink)
References <qk426-2gx-3@gated-at.bofh.it> <qkiop-6zg-7@gated-at.bofh.it> <qkkJz-1Ic-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Friday 16 October 2015 14:22:15 Joe Perches wrote:
> On Fri, 2015-10-16 at 21:50 +0300, Sergei Shtylyov wrote:
> > On 10/16/2015 09:04 PM, Joe Perches wrote:
> > 
> > >>>> BITS_RX_EN is an 'unsigned long' constant, so the ones complement of that
> > >>>> has bits set that do not fit into a 32-bit variable on 64-bit architectures,
> > >>>> which causes a harmless gcc warning:
> > >>> ...
> > >>>>   static void hix5hd2_port_disable(struct hix5hd2_priv *priv)
> > >>>>   {
> > >>>> -     writel_relaxed(~(BITS_RX_EN | BITS_TX_EN), priv->base + PORT_EN);
> > >>>> +     writel_relaxed(~(u32)(BITS_RX_EN | BITS_TX_EN), priv->base + PORT_EN);
> > >>>>        writel_relaxed(0, priv->base + DESC_WR_RD_ENA);
> > >>>
> > >>> ISTM that just means that the constants shouldn't be 'long'.
> > >>
> > >> Right, but that would probably mean changing the BIT() macro or not using it
> > >> here. In the past I've argued against using that macro, but I've given
> > >> up that fight.
> > >
> > > Fight on... (Somebody must have gone to USC here)

Ok, I'll try:

Please stop this nonsense!

;-)

> > > There might be value in aefin BIT_U32 macro.
> > > Maybe BIT_U64 too.
> > 
> >     There's BIT_ULL() already.
> 
> I know, but symmetry is good.
> I think there'd be no harm in adding it.
> Perhaps adding all the sized variants would be useful.
> 
> Something like:
> 
> #define BIT_OF_TYPE(type, nr)						\
> ({									\
> 	typeof(type) rtn;						\
> 	BUILD_BUG_ON(__builtin_constant_p(nr) &&			\
> 		     ((nr) < 0 ||					\
> 		      (nr) >= sizeof(type) * BITS_PER_BYTE));		\
> 	rtn = ((type)1) << (nr);					\
> 	rtn;								\
> })
> 
> #define BIT_U8(nr)	BIT_OF_TYPE(u8, nr)
> #define BIT_U16(nr)	BIT_OF_TYPE(u16, nr)
> #define BIT_U32(nr)	BIT_OF_TYPE(u32, nr)
> #define BIT_U64(nr)	BIT_OF_TYPE(u64, nr)

As I said, I'd rather see less uses of BIT() instead of more. While
using 'BIT(23)' is often than the open-coded '1 << 23', I wish more
people would write that as '0x00800000' instead. It's easier to
match with data sheets, and to compare to printk output, plus
it's non-ambiguous if you are dealing with data sheets that use
the IBM convention of counting the bits from the other end.

	Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH net-next v3 0/2] net: hisilicon fix some bugs in HNS drivers huangdaode <huangdaode@hisilicon.com> - 2015-10-16 05:40 +0200
  [PATCH net-next v3 1/2] net: hisilicon rm hnae sysfs interface huangdaode <huangdaode@hisilicon.com> - 2015-10-16 05:40 +0200
    Re: [PATCH net-next v3 1/2] net: hisilicon rm hnae sysfs interface Arnd Bergmann <arnd@arndb.de> - 2015-10-16 11:30 +0200
  [PATCH] net: hisilicon: include linux/vmalloc.h in dsaf Arnd Bergmann <arnd@arndb.de> - 2015-10-16 11:40 +0200
  [PATCH] net: hisilicon: add OF dependency Arnd Bergmann <arnd@arndb.de> - 2015-10-16 11:40 +0200
    Re: [PATCH] net: hisilicon: add OF dependency kbuild test robot <lkp@intel.com> - 2015-10-16 19:10 +0200
    Re: [PATCH] net: hisilicon: add OF dependency kbuild test robot <lkp@intel.com> - 2015-10-16 20:20 +0200
      Re: [PATCH] net: hisilicon: add OF dependency Joe Perches <joe@perches.com> - 2015-10-16 20:30 +0200
  Re: [PATCH net-next v3 0/2] net: hisilicon fix some bugs in HNS drivers Arnd Bergmann <arnd@arndb.de> - 2015-10-16 11:40 +0200
  [PATCH] net: hix5hd2_gmac: avoid integer overload warning Arnd Bergmann <arnd@arndb.de> - 2015-10-16 12:10 +0200
    RE: [PATCH] net: hix5hd2_gmac: avoid integer overload warning David Laight <David.Laight@ACULAB.COM> - 2015-10-16 13:20 +0200
      Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Arnd Bergmann <arnd@arndb.de> - 2015-10-16 13:30 +0200
        Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Joe Perches <joe@perches.com> - 2015-10-16 20:10 +0200
          Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-16 21:00 +0200
            Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Joe Perches <joe@perches.com> - 2015-10-16 23:30 +0200
              Re: [PATCH] net: hix5hd2_gmac: avoid integer overload warning Arnd Bergmann <arnd@arndb.de> - 2015-10-16 23:50 +0200

csiph-web