Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1248905

[PATCH 2/3] pstore: add a helper function pstore_register_kmsg

From Geliang Tang <geliangtang@163.com>
Newsgroups linux.kernel
Subject [PATCH 2/3] pstore: add a helper function pstore_register_kmsg
Date 2015-10-16 17:40 +0200
Message-ID <qkfgS-25r-27@gated-at.bofh.it> (permalink)
References <qkf7d-1SN-51@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Add a new wraper function pstore_register_kmsg to keep the
consistency with the other similar pstore_register_* functions.

Signed-off-by: Geliang Tang <geliangtang@163.com>
---
 Send it again.
---
 fs/pstore/platform.c | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/fs/pstore/platform.c b/fs/pstore/platform.c
index 791743d..1b11249 100644
--- a/fs/pstore/platform.c
+++ b/fs/pstore/platform.c
@@ -353,6 +353,11 @@ static struct kmsg_dumper pstore_dumper = {
 	.dump = pstore_dump,
 };
 
+static void pstore_register_kmsg(void)
+{
+	kmsg_dump_register(&pstore_dumper);
+}
+
 #ifdef CONFIG_PSTORE_CONSOLE
 static void pstore_console_write(struct console *con, const char *s, unsigned c)
 {
@@ -442,7 +447,7 @@ int pstore_register(struct pstore_info *psi)
 	if (pstore_is_mounted())
 		pstore_get_records(0);
 
-	kmsg_dump_register(&pstore_dumper);
+	pstore_register_kmsg();
 
 	if ((psi->flags & PSTORE_FLAGS_FRAGILE) == 0) {
 		pstore_register_console();
-- 
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] pstore: add vmalloc error check Geliang Tang <geliangtang@163.com> - 2015-10-16 17:30 +0200
  [PATCH 3/3] pstore: add 'rmmod ramoops' support Geliang Tang <geliangtang@163.com> - 2015-10-16 17:30 +0200
    Re: [PATCH 3/3] pstore: add 'rmmod ramoops' support Kees Cook <keescook@chromium.org> - 2015-10-16 18:00 +0200
  [PATCH 2/3] pstore: add a helper function pstore_register_kmsg Geliang Tang <geliangtang@163.com> - 2015-10-16 17:40 +0200

csiph-web