Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1247029
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCHv3 08/11] arm64: Check for selected granule support |
| Date | 2015-10-14 19:40 +0200 |
| Message-ID | <qjybV-5uA-29@gated-at.bofh.it> (permalink) |
| References | <qjspQ-5qz-3@gated-at.bofh.it> <qjspQ-5qz-9@gated-at.bofh.it> <qjy2f-5jz-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, Oct 14, 2015 at 06:24:18PM +0100, Mark Rutland wrote: > > @@ -613,10 +614,28 @@ ENDPROC(__secondary_switched) > > * x0 = SCTLR_EL1 value for turning on the MMU. > > * x27 = *virtual* address to jump to upon completion > > * > > - * other registers depend on the function called upon completion > > + * Other registers depend on the function called upon completion. > > + * > > + * Checks if the selected granule size is supported by the CPU. > > + * If it doesn't park the CPU > > Nit: "If it isn't, park the CPU." > > > */ > > +#if defined(CONFIG_ARM64_64K_PAGES) > > + > > +#define id_aa64mmfr0_tgran_shift ID_AA64MMFR0_TGRAN64_SHIFT > > +#define id_aa64mmfr0_tgran_on ID_AA64MMFR0_TGRAN64_ON > > + > > +#else > > + > > +#define id_aa64mmfr0_tgran_shift ID_AA64MMFR0_TGRAN4_SHIFT > > +#define id_aa64mmfr0_tgran_on ID_AA64MMFR0_TGRAN4_ON > > Any reason for not using upper-case names for the macros? > > Given they're local you could just call them TGRAN_SHIFT and TRGRAN_ON > to make the asm slightly nicer. Actually, even better, s/TGRAN_ON/TGRAN_SUPPORTED/ Mark. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <suzuki.poulose@arm.com> - 2015-10-14 13:30 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-14 19:30 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-14 19:40 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-15 11:50 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-15 12:40 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Jeremy Linton <jeremy.linton@arm.com> - 2015-10-14 23:20 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-15 11:50 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-15 12:50 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-15 13:30 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-15 14:40 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-15 15:00 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2015-10-16 10:10 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Jeremy Linton <jeremy.linton@arm.com> - 2015-10-15 16:50 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support "Suzuki K. Poulose" <Suzuki.Poulose@arm.com> - 2015-10-15 17:10 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Mark Rutland <mark.rutland@arm.com> - 2015-10-15 17:20 +0200
Re: [PATCHv3 08/11] arm64: Check for selected granule support Ard Biesheuvel <ard.biesheuvel@linaro.org> - 2015-10-16 10:20 +0200
csiph-web