Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1246786

Re: [PATCH 1/2] kconfig/merge_config.sh: Support KCONFIG_CONFIG

From Gabriel de Perthuis <g2p.code@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 1/2] kconfig/merge_config.sh: Support KCONFIG_CONFIG
Date 2015-10-14 16:00 +0200
Message-ID <qjuL2-k6-49@gated-at.bofh.it> (permalink)
References <q6RvH-1rs-1@gated-at.bofh.it> <qjrWO-4AF-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Le 14/10/2015 à 12:56, Michal Marek a écrit :
> On 2015-09-09 19:33, Gabriel de Perthuis wrote:
>> All make targets support $KCONFIG_CONFIG because they
>> run scripts/kconf.  Make sure merge_config.sh accesses the
>> correct file in all cases.
>>
>> Previously this script broke in two different code paths,
>> one for targets like kvmconfig (which use merge_config.sh -m
>> then call a target that respects KCONFIG_CONFIG) and one for
>> direct use of the script without -m, which called make rules
>> that edit KCONFIG_CONFIG but verified a different file.
>>
>> Signed-off-by: Gabriel de Perthuis <g2p.code@gmail.com>
>> Cc: Michal Marek <mmarek@suse.cz>
>> ---
>>    scripts/kconfig/merge_config.sh | 6 +++---
>>    1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/scripts/kconfig/merge_config.sh
>> b/scripts/kconfig/merge_config.sh
>> index 0d883b3..5f1e110 100755
>> --- a/scripts/kconfig/merge_config.sh
>> +++ b/scripts/kconfig/merge_config.sh
>> @@ -122,13 +122,13 @@ for MERGE_FILE in $MERGE_LIST ; do
>>    	done
>>    	cat $MERGE_FILE >> $TMP_FILE
>>    done
>>     if [ "$RUNMAKE" = "false" ]; then
>> -	cp $TMP_FILE $OUTPUT/.config
>> +	cp $TMP_FILE ${KCONFIG_CONFIG:=$OUTPUT/.config}
>>    	echo "#"
>> -	echo "# merged configuration written to $OUTPUT/.config (needs make)"
>> +	echo "# merged configuration written to $KCONFIG_CONFIG (needs make)"
>
> The message will not contain the name of the output file when invoked
> directly and without the variable set.

Don't miss the ${:=} assignments.

 > Also, it will be more readable if you set the default value once and 
then use simply $KCONFIG_CONFIG.

I'll resubmit something more explicit, pick whichever you prefer.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH 1/2] kconfig/merge_config.sh: Support KCONFIG_CONFIG Michal Marek <mmarek@suse.cz> - 2015-10-14 13:00 +0200
  Re: [PATCH 1/2] kconfig/merge_config.sh: Support KCONFIG_CONFIG Gabriel de Perthuis <g2p.code@gmail.com> - 2015-10-14 16:00 +0200
    Re: [PATCH 1/2] kconfig/merge_config.sh: Support KCONFIG_CONFIG Michal Marek <mmarek@suse.cz> - 2015-10-14 16:20 +0200

csiph-web