Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1246526

Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node

From Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Newsgroups linux.kernel
Subject Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node
Date 2015-10-14 13:10 +0200
Message-ID <qjs6u-52j-35@gated-at.bofh.it> (permalink)
References <qj4dQ-2vA-17@gated-at.bofh.it> <qj4dQ-2vA-31@gated-at.bofh.it> <qj8Ua-Wq-19@gated-at.bofh.it> <qjiJQ-7iz-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello.

On 10/14/2015 4:07 AM, Daniel Kurtz wrote:

>>> Add Mediatek nor flash node
>>>
>>> Signed-off-by: Bayi Cheng <bayi.cheng@mediatek.com>
>>> ---
>>>    arch/arm64/boot/dts/mediatek/mt8173.dtsi | 15 +++++++++++++++
>>>    1 file changed, 15 insertions(+)
>>>
>>> diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>> b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>> index d18ee42..385c2e4 100644
>>> --- a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>> +++ b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
>>> @@ -365,6 +365,21 @@
>>>                          status = "disabled";
>>>                  };
>>>
>>> +               nor_flash: spi@1100d000 {
>>
>>     I don't think this is a good label name for a SPI controller.
>
> You think "spi" is not a good name for SPI controller?
> Or you mean the label "nor_flash"?

    I think I said clearly: "label". :-)

> Would you prefer:
>
>    spi_nor_flash: spi@1100d000

    I'd prefer the "_nor_flash" part to be dropped, to be used for the real 
flash device (if needed) which is a sub-node of this node.

[...]

> -Dan

MBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 0/3] Mediatek SPI-NOR flash driver  Bayi Cheng <bayi.cheng@mediatek.com> - 2015-10-13 11:40 +0200
  [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node Bayi Cheng <bayi.cheng@mediatek.com> - 2015-10-13 11:40 +0200
    Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-13 16:40 +0200
      Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node Daniel Kurtz <djkurtz@chromium.org> - 2015-10-14 03:10 +0200
        Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node Sergei Shtylyov <sergei.shtylyov@cogentembedded.com> - 2015-10-14 13:10 +0200
          Re: [PATCH v4 3/3] arm64: dts: mt8173: Add nor flash node Daniel Kurtz <djkurtz@chromium.org> - 2015-10-14 13:30 +0200
  [PATCH v4 1/3] doc: dt: add documentation for Mediatek spi-nor controller Bayi Cheng <bayi.cheng@mediatek.com> - 2015-10-13 11:50 +0200
    Re: [PATCH v4 1/3] doc: dt: add documentation for Mediatek spi-nor  controller Brian Norris <computersforpeace@gmail.com> - 2015-10-16 03:30 +0200
  [PATCH v4 2/3] mtd: mtk-nor: mtk serial flash controller driver Bayi Cheng <bayi.cheng@mediatek.com> - 2015-10-13 11:50 +0200
    Re: [PATCH v4 2/3] mtd: mtk-nor: mtk serial flash controller driver Brian Norris <computersforpeace@gmail.com> - 2015-10-16 09:50 +0200

csiph-web