Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1245974
| From | Jason Gunthorpe <jgunthorpe@obsidianresearch.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/4] tpm: seal/unseal for TPM 2.0 |
| Date | 2015-10-13 19:40 +0200 |
| Message-ID | <qjbIm-53L-39@gated-at.bofh.it> (permalink) |
| References | <qf42K-6wc-5@gated-at.bofh.it> <qf42K-6wc-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Fri, Oct 02, 2015 at 11:38:17AM +0300, Jarkko Sakkinen wrote: > Added tpm_trusted_seal() and tpm_trusted_unseal() API for sealing > trusted keys. > > This patch implements basic sealing and unsealing functionality for > TPM 2.0: We really need to stop using chip id's as a handle - the caller should be using a pointer, it is just a horrible API, and the TPM_ANY_NUM business is awful too.. TPM's are stateful devices! Is it feasible to introduce new APIs with a saner scheme? The api layering also seems really weird to me. At a minimum the tpm_seal_trusted should be called within key_seal, but really, should key_seal be migrated into the TPM core? I'm not sure it makes alot of sense to have a tpm_seal_trusted which uses the high level key structs when other tpm functions are all low level RPC wrappers... Jason -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH 3/4] tpm: seal/unseal for TPM 2.0 Jason Gunthorpe <jgunthorpe@obsidianresearch.com> - 2015-10-13 19:40 +0200 Re: [PATCH 3/4] tpm: seal/unseal for TPM 2.0 Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com> - 2015-10-13 21:50 +0200
csiph-web