Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1244010
| From | Dan Williams <dan.j.williams@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t |
| Date | 2015-10-10 23:00 +0200 |
| Message-ID | <qi9pg-3Oh-3@gated-at.bofh.it> (permalink) |
| References | <qhQPE-2hO-5@gated-at.bofh.it> <qhQPF-2hO-17@gated-at.bofh.it> <qi95U-3qj-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, Oct 10, 2015 at 1:35 PM, Paolo Bonzini <pbonzini@redhat.com> wrote: > On 10/10/2015 02:56, Dan Williams wrote: >> The core has developed a need for a "pfn_t" type [1]. Move the existing >> pfn_t in KVM to kvm_pfn_t [2]. >> >> [1]: https://lists.01.org/pipermail/linux-nvdimm/2015-September/002199.html >> [2]: https://lists.01.org/pipermail/linux-nvdimm/2015-September/002218.html > > Can you please change also the other types in include/linux/kvm_types.h? Hmm, all those seem kvm specific already. I'd only prefix them with kvm_ if they collided with a "core" type. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/20] get_user_pages() for dax mappings Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 09/20] frv: fix compiler warning from definition of __pmd() Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 07/20] avr32: convert to asm-generic/memory_model.h Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 15/20] mm, dax: convert vmf_insert_pfn_pmd() to pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 18/20] block: notify queue death confirmation Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 12/20] mips: fix PAGE_MASK definition Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Christoffer Dall <christoffer.dall@linaro.org> - 2015-10-10 17:40 +0200
Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Paolo Bonzini <pbonzini@redhat.com> - 2015-10-10 22:40 +0200
Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-10 23:00 +0200
Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Paolo Bonzini <pbonzini@redhat.com> - 2015-10-12 15:00 +0200
Re: [PATCH v2 11/20] kvm: rename pfn_t to kvm_pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-12 18:20 +0200
[PATCH v2 01/20] block: generic request_queue reference counting Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
Re: [PATCH v2 01/20] block: generic request_queue reference counting Christoph Hellwig <hch@lst.de> - 2015-10-11 15:00 +0200
Re: [PATCH v2 01/20] block: generic request_queue reference counting Dan Williams <dan.j.williams@intel.com> - 2015-10-13 02:10 +0200
[PATCH v2 03/20] block, dax: fix lifetime of in-kernel dax mappings with dax_map_atomic() Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 04/20] mm: introduce __get_dev_pagemap() Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 02/20] dax: increase granularity of dax_clear_blocks() operations Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 19/20] mm, pmem: devm_memunmap_pages(), truncate and unmap ZONE_DEVICE pages Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 16/20] list: introduce list_poison() and LIST_POISON3 Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 20/20] mm, x86: get_user_pages() for dax mappings Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 06/20] libnvdimm, pfn, pmem: allocate memmap array in persistent memory Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 05/20] x86, mm: introduce vmem_altmap to augment vmemmap_populate() Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 10/20] um: kill pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 17/20] mm, dax, pmem: introduce {get|put}_dev_pagemap() for dax-gup Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
[PATCH v2 13/20] mm, dax, pmem: introduce pfn_t Dan Williams <dan.j.williams@intel.com> - 2015-10-10 03:10 +0200
csiph-web