Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1239416
| From | David Miller <davem@davemloft.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 05/14] RDS: defer the over_batch work to send worker |
| Date | 2015-10-05 12:20 +0200 |
| Message-ID | <qgb2b-4nd-15@gated-at.bofh.it> (permalink) |
| References | <qetmx-3dp-5@gated-at.bofh.it> <qetwd-3ox-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Santosh Shilimkar <santosh.shilimkar@oracle.com>
Date: Wed, 30 Sep 2015 13:24:24 -0400
> @@ -423,7 +423,9 @@ over_batch:
> !list_empty(&conn->c_send_queue)) &&
> send_gen == conn->c_send_gen) {
> rds_stats_inc(s_send_lock_queue_raced);
> - goto restart;
> + if (batch_count < 1024)
> + goto restart;
> + queue_delayed_work(rds_wq, &conn->c_send_w, 1);
Sorry, you can't just use a magic number like this.
You have to describe, in detail, exactly how this value was
choosen, derived, and tested to be effeective and in exactly
what environment those tests were done.
You must also use a mnenomic for this value rather than a
raw magic constant.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 00/14] RDS: connection scalability and performance improvements Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:30 +0200
[PATCH v2 13/14] RDS: IB: use max_mr from HCA caps than max_fmr Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:30 +0200
[PATCH v2 07/14] RDS: IB: ack more receive completions to improve performance Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:30 +0200
[PATCH v2 08/14] RDS: IB: split send completion handling and do batch ack Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:30 +0200
[PATCH v2 05/14] RDS: defer the over_batch work to send worker Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:40 +0200
Re: [PATCH v2 05/14] RDS: defer the over_batch work to send worker David Miller <davem@davemloft.net> - 2015-10-05 12:20 +0200
Re: [PATCH v2 05/14] RDS: defer the over_batch work to send worker santosh shilimkar <santosh.shilimkar@oracle.com> - 2015-10-05 17:40 +0200
[PATCH v2 03/14] RDS: fix rds_sock reference bug while doing bind Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:40 +0200
[PATCH v2 02/14] RDS: make socket bind/release locking scheme simple and more efficient Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:40 +0200
[PATCH v2 06/14] RDS: use rds_send_xmit() state instead of RDS_LL_SEND_FULL Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:40 +0200
[PATCH v2 04/14] RDS: Use per-bucket rw lock for bind hash-table Santosh Shilimkar <santosh.shilimkar@oracle.com> - 2015-09-30 19:40 +0200
RE: [PATCH v2 00/14] RDS: connection scalability and performance improvements David Laight <David.Laight@ACULAB.COM> - 2015-10-01 18:30 +0200
Re: [PATCH v2 00/14] RDS: connection scalability and performance improvements "santosh.shilimkar@oracle.com" <santosh.shilimkar@oracle.com> - 2015-10-01 21:10 +0200
csiph-web