Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1241043

Re: [PATCH] linux/thermal.h: rename KELVIN_TO_CELSIUS to DECI_KELVIN_TO_CELSIUS

From Darren Hart <dvhart@infradead.org>
Newsgroups linux.kernel
Subject Re: [PATCH] linux/thermal.h: rename KELVIN_TO_CELSIUS to DECI_KELVIN_TO_CELSIUS
Date 2015-10-07 00:40 +0200
Message-ID <qgJ3Q-2UE-13@gated-at.bofh.it> (permalink)
References <qeTTI-eK-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Oct 01, 2015 at 11:45:31PM +0200, Rasmus Villemoes wrote:
> The macros KELVIN_TO_CELSIUS and CELSIUS_TO_KELVIN actually convert
> between deciKelvins and Celsius, so rename them to reflect that. While
> at it, use a statement expression in DECI_KELVIN_TO_CELSIUS to prevent
> expanding the argument multiple times and get rid of a few casts.
> 
> Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>

If Zhang and Rafael are happy with the termal change, then for the
resulting platform/drivers/x86 changes:

Acked-by: Darren Hart <dvhart@linux.intel.com>

-- 
Darren Hart
Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH] linux/thermal.h: rename KELVIN_TO_CELSIUS to  DECI_KELVIN_TO_CELSIUS Darren Hart <dvhart@infradead.org> - 2015-10-07 00:40 +0200

csiph-web