Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1239151

Re: [PATCH 1/3] signal: turn dequeue_signal_lock() into kernel_dequeue_signal()

From Tejun Heo <tj@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 1/3] signal: turn dequeue_signal_lock() into kernel_dequeue_signal()
Date 2015-10-04 18:40 +0200
Message-ID <qfUul-5M0-1@gated-at.bofh.it> (permalink)
References <qfzzA-1bp-5@gated-at.bofh.it> <qfzzA-1bp-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, Oct 03, 2015 at 08:13:36PM +0200, Oleg Nesterov wrote:
> 1. Rename dequeue_signal_lock() to kernel_dequeue_signal(). This
>    matches another "for kthreads only" kernel_sigaction() helper.
> 
> 2. Remove the "tsk" and "mask" arguments, they are always current
>    and current->blocked. And it is simply wrong if tsk != current.
> 
> 3. We could also remove the 3rd "siginfo_t *info" arg but it looks
>    potentially useful. However we can simplify the callers if we
>    change kernel_dequeue_signal() to accept info => NULL.
> 
> 4. Remove _irqsave, it is never called from atomic context.
> 
> Signed-off-by: Oleg Nesterov <oleg@redhat.com>

FWIW, looks good to me.

Reviewed-by: Tejun Heo <tj@kernel.org>

Thanks.

-- 
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] signal: turn dequeue_signal_lock() into  kernel_dequeue_signal() Oleg Nesterov <oleg@redhat.com> - 2015-10-03 20:20 +0200
  Re: [PATCH 1/3] signal: turn dequeue_signal_lock() into  kernel_dequeue_signal() Tejun Heo <tj@kernel.org> - 2015-10-04 18:40 +0200

csiph-web