Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1237612

[PATCH v2 3/5] firmware: fold successful fw read early

From "Luis R. Rodriguez" <mcgrof@do-not-panic.com>
Newsgroups linux.kernel
Subject [PATCH v2 3/5] firmware: fold successful fw read early
Date 2015-10-01 20:00 +0200
Message-ID <qeQj9-3kO-39@gated-at.bofh.it> (permalink)
References <qeQ9s-39m-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: David Howells <dhowells@redhat.com>

We'll be folding in some more checks on fw_read_file_contents(),
this will make the success case easier to follow.

Signed-off-by: David Howells <dhowells@redhat.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
---
 drivers/base/firmware_class.c | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)

diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index d8148aa89b01..e10a5349aa61 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -361,20 +361,18 @@ static int fw_get_filesystem_firmware(struct device *device,
 			continue;
 		rc = fw_read_file_contents(file, buf);
 		fput(file);
-		if (rc)
+		if (rc == 0) {
+			dev_dbg(device, "system data: direct-loading firmware %s\n",
+				buf->fw_id);
+			fw_finish_direct_load(device, buf);
+			goto out;
+		} else
 			dev_warn(device, "system data, attempted to load %s, but failed with error %d\n",
 				 path, rc);
-		else
-			break;
 	}
+out:
 	__putname(path);
 
-	if (!rc) {
-		dev_dbg(device, "system data: direct-loading firmware %s\n",
-			buf->fw_id);
-		fw_finish_direct_load(device, buf);
-	}
-
 	return rc;
 }
 
-- 
2.4.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH v2 0/5] firmware_class: extensible firmware API "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 19:50 +0200
  [PATCH v2 1/5] firmware: generalize "firmware" as "system data" helpers "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 19:50 +0200
  [PATCH v2 2/5] firmware: move completing fw into a helper "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 20:00 +0200
  [PATCH v2 4/5] firmware: generalize reading file contents as a helper "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 20:00 +0200
  [PATCH v2 5/5] firmware: add an extensible system data helpers "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 20:00 +0200
  [PATCH v2 3/5] firmware: fold successful fw read early "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-10-01 20:00 +0200

csiph-web