Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1237582
| From | Dave Hansen <dave@sr71.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK |
| Date | 2015-10-01 19:20 +0200 |
| Message-ID | <qePGq-2Bk-19@gated-at.bofh.it> (permalink) |
| References | <qdM7T-59-3@gated-at.bofh.it> <qdMhB-gH-41@gated-at.bofh.it> <qeKGK-383-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 10/01/2015 04:54 AM, Thomas Gleixner wrote: > On Mon, 28 Sep 2015, Dave Hansen wrote: >> > >> > /* >> > @@ -916,7 +918,10 @@ static int spurious_fault_check(unsigned >> > >> > if ((error_code & PF_INSTR) && !pte_exec(*pte)) >> > return 0; >> > - >> > + /* >> > + * Note: We do not do lazy flushing on protection key >> > + * changes, so no spurious fault will ever set PF_PK. >> > + */ > It might be a bit more clear to have: > > /* Comment .... */ > if ((error_code & PF_PK)) > return 1; > > return 1; > > That way the comment is associated to obviously redundant code, but > it's easier to read, especially if we add some new PF_ thingy after > that. Agreed, that's a nicer way to do it. I'll fix it up. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/25] x86: Memory Protection Keys Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
[PATCH 21/25] mm: implement new mprotect_key() system call Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
Re: [PATCH 21/25] mm: implement new mprotect_key() system call Michael Ellerman <mpe@ellerman.id.au> - 2015-09-29 08:40 +0200
Re: [PATCH 21/25] mm: implement new mprotect_key() system call Dave Hansen <dave@sr71.net> - 2015-09-29 16:20 +0200
[PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
Re: [PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK Thomas Gleixner <tglx@linutronix.de> - 2015-10-01 14:00 +0200
Re: [PATCH 07/25] x86, pkeys: new page fault error code bit: PF_PK Dave Hansen <dave@sr71.net> - 2015-10-01 19:20 +0200
[PATCH 16/25] x86, pkeys: optimize fault handling in access_error() Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
[PATCH 13/25] mm: factor out VMA fault permission checking Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
[PATCH 08/25] x86, pkeys: store protection in high VMA flags Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
[PATCH 06/25] x86, pkeys: PTE bits for storing protection key Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
[PATCH 14/25] mm: simplify get_user_pages() PTE bit handling Dave Hansen <dave@sr71.net> - 2015-09-28 21:30 +0200
csiph-web