Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1237543
| From | "Meyer, Mike" <Mike.Meyer@Teradata.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH] sched: fix task and run queue run_delay inconsistencies |
| Date | 2015-10-01 18:10 +0200 |
| Message-ID | <qeOAI-15a-47@gated-at.bofh.it> (permalink) |
| References | <qbGJj-5Ao-1@gated-at.bofh.it> <qerNN-SV-59@gated-at.bofh.it> <qewaK-7gv-5@gated-at.bofh.it> <qeFH4-4bi-11@gated-at.bofh.it> <qeIEW-gR-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
> On Thu, Oct 01, 2015 at 08:37:32AM +0200, Peter Zijlstra wrote: > > > > On Wed, Sep 30, 2015 at 08:28:41PM +0000, Meyer, Mike wrote: > > It looks like the sites in the wakeup path do indeed not get any additional > conditionals. > > > > My only comment is I am not sure about the naming of the flag > > > ENQUEUE_TEMP which implies (to me) the enqueue is temporary which > > > clearly it isn't. Maybe something like > DEQUEUE_MOVE/ENQUEUE_MOVE > > > would be a bit more descriptive of the use case. > > > > Yes, I ran out of creative juices, let me attempt a better name once > > I've woken up a bit. > > How about DEQUEUE_SAVE, ENQUEUE_RESTORE ? Ideally I'd wrap the whole > pattern into a helper but C isn't really supportive of pre+post patterns like > this. Sounds fine to me! Thanks again. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] sched: fix task and run queue run_delay inconsistencies "Meyer, Mike" <Mike.Meyer@Teradata.com> - 2015-09-23 03:10 +0200
Re: [PATCH] sched: fix task and run queue run_delay inconsistencies Peter Zijlstra <peterz@infradead.org> - 2015-09-30 17:50 +0200
RE: [PATCH] sched: fix task and run queue run_delay inconsistencies "Meyer, Mike" <Mike.Meyer@Teradata.com> - 2015-09-30 22:30 +0200
Re: [PATCH] sched: fix task and run queue run_delay inconsistencies Peter Zijlstra <peterz@infradead.org> - 2015-10-01 08:40 +0200
Re: [PATCH] sched: fix task and run queue run_delay inconsistencies Peter Zijlstra <peterz@infradead.org> - 2015-10-01 11:50 +0200
RE: [PATCH] sched: fix task and run queue run_delay inconsistencies "Meyer, Mike" <Mike.Meyer@Teradata.com> - 2015-10-01 18:10 +0200
csiph-web