Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1235376

Re: [PATCH] btrfs: remove unneeded NULL initializer for struct fs_path

From Alexandru Moise <00moses.alexander00@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH] btrfs: remove unneeded NULL initializer for struct fs_path
Date 2015-09-29 18:40 +0200
Message-ID <qe66D-3vi-39@gated-at.bofh.it> (permalink)
References <qcTEu-3SO-3@gated-at.bofh.it> <qe2mn-6A8-29@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Sep 29, 2015 at 02:32:29PM +0200, David Sterba wrote:
> On Sat, Sep 26, 2015 at 12:05:19PM +0000, Alexandru Moise wrote:
> > fs_path_alloc() either returns an alloc'ed struct fs_path
> > or NULL, no need to initialize the pointer to NULL.
> > 
> > Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com>
> > ---
> >  fs/btrfs/send.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/btrfs/send.c b/fs/btrfs/send.c
> > index aa72bfd..0019c90 100644
> > --- a/fs/btrfs/send.c
> > +++ b/fs/btrfs/send.c
> > @@ -2230,7 +2230,7 @@ static int get_cur_path(struct send_ctx *sctx, u64 ino, u64 gen,
> >  			struct fs_path *dest)
> >  {
> >  	int ret = 0;
> > -	struct fs_path *name = NULL;
> > +	struct fs_path *name;
> 
> I'd rather see all such instances fixed in one patch. Quick grep
> revealed a few more. OTOH this kind of extra initialization is harmless
> and sometimes help readability, it's clear that he value is zeroed.

When you put it like that, you are right, it's more important to make
things obvious than to fiercely abide by all the subtleties of our
coding style. I submit to your point of view and will not insist on
this kind of change in the future.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] btrfs: remove unneeded NULL initializer for struct fs_path Alexandru Moise <00moses.alexander00@gmail.com> - 2015-09-26 11:10 +0200
  Re: [PATCH] btrfs: remove unneeded NULL initializer for struct  fs_path David Sterba <dsterba@suse.cz> - 2015-09-29 14:40 +0200
    Re: [PATCH] btrfs: remove unneeded NULL initializer for struct  fs_path Alexandru Moise <00moses.alexander00@gmail.com> - 2015-09-29 18:40 +0200

csiph-web