Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1232096
| From | Sudeep Holla <sudeep.holla@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 4/5] ACPI / processor_idle : introduce ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE |
| Date | 2015-09-24 15:10 +0200 |
| Message-ID | <qcerE-3X9-23@gated-at.bofh.it> (permalink) |
| References | <pTOvF-HG-17@gated-at.bofh.it> <q9lpF-6fG-33@gated-at.bofh.it> <q9lpF-6fG-31@gated-at.bofh.it> <qcc6u-q6-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 24/09/15 11:31, Ashwin Chaugule wrote: > Hi Sudeep, > > On 16 September 2015 at 09:59, Sudeep Holla <sudeep.holla@arm.com> wrote: >> ACPI 6.0 adds a new method to specify the CPU idle states(C-states) >> called Low Power Idle(LPI) states. Since new architectures like ARM64 >> use only LPIs, introduce ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE to >> encapsulate all the code supporting the old style C-states(_CST) >> >> This patch will help to extend the processor_idle module to support >> LPI. >> >> Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net> >> Signed-off-by: Sudeep Holla <sudeep.holla@arm.com> [...] >> diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig >> index 7aef2d52daa0..173075c48df8 100644 >> --- a/arch/x86/Kconfig >> +++ b/arch/x86/Kconfig >> @@ -34,6 +34,7 @@ config X86 >> select ARCH_MIGHT_HAVE_ACPI_PDC if ACPI >> select ARCH_MIGHT_HAVE_PC_PARPORT >> select ARCH_MIGHT_HAVE_PC_SERIO >> + select ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE if ACPI >> select ARCH_SUPPORTS_ATOMIC_RMW >> select ARCH_SUPPORTS_DEFERRED_STRUCT_PAGE_INIT >> select ARCH_SUPPORTS_INT128 if X86_64 >> diff --git a/drivers/acpi/Kconfig b/drivers/acpi/Kconfig >> index 5d1015c26ff4..1eb0b8a84a65 100644 >> --- a/drivers/acpi/Kconfig >> +++ b/drivers/acpi/Kconfig >> @@ -48,6 +48,9 @@ config ACPI_LEGACY_TABLES_LOOKUP >> config ARCH_MIGHT_HAVE_ACPI_PDC >> bool >> >> +config ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE >> + bool >> + >> config ACPI_GENERIC_GSI >> bool >> > > Can't this be auto selected under ACPI_PROCESSOR_IDLE if X86 || IA64 > instead? It can be done. The idea was to have ACPI_PROCESSOR_IDLE selected on both x86 and ARM64. processor_idle driver will support both _CST and _LPI 1. to avoid some code duplication 2. for easy enabling of _LPI on x86 if needed in future Regards, Sudeep -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v2 4/5] ACPI / processor_idle : introduce ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE Ashwin Chaugule <ashwin.chaugule@linaro.org> - 2015-09-24 12:40 +0200 Re: [PATCH v2 4/5] ACPI / processor_idle : introduce ARCH_SUPPORTS_ACPI_PROCESSOR_CSTATE Sudeep Holla <sudeep.holla@arm.com> - 2015-09-24 15:10 +0200
csiph-web