Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1231470
| From | Peter Rosin <peda@lysator.liu.se> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v6 0/2] Driver for Microchip digital potentiometers |
| Date | 2015-09-23 16:30 +0200 |
| Message-ID | <qbTdv-6LJ-7@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
From: Peter Rosin <peda@axentia.se> This is the sixth attempt for a driver for these chips. Thanks for review comments from Greg Kroah-Hartman, Crt Mori, Daniel Baluta, Lars-Peter Clauson, Andreas Dannenberg, Peter Meerwald and Jonathan Cameron. I think and hope I got it all sorted. Changes since v5: - Use a symbolic name to index the cfg array (Lars-Peter) - Consolidate handling of MCP4xx1 and MCP4xx2 (me) Changes since v4: - Less convoluted changelog (Jonathan) - Use an index into an array of configs as dev_id (Jonathan) - Drop .address and use .channel (Jonathan) - Remove one layer of wrappers (Jonathan) - Provide a scale (Jonathan, Lars-Peter) Changes since v3: - Use i2c_smbus_read_word_swapped (Peter) - Use devm_iio_device_register and drop the mcp4531_remove op (Peter) - Add defines for a few magic numbers (Peter) - Deduplicate channel params with a macro (Peter) - Mention the i2c client address options (Peter) - Whitespace and other trivial nits (Peter) Changes since v2: - Change naming from mcp4xxx_dpot to mcp4531 (Daniel) - Added links to datasheet in commit message and source (Daniel) - Rename from pot to potentiometer (Daniel, Crt) - Use IIO_RESISTANCE instead of IIO_STEPS (Crt, Lars-Peter) - Don't use wildcards in MAINTAINERS and point to the iio list (Crt) - Avoid races by not caching values (Crt) - Spell Microchip correctly (Andreas) Changes since v1: - Make it an IIO driver instead (Greg) - Don't convolute the code with big obscure macros (Greg) - Inline the bits from mcp4xxx_dpot.h that are actually used and drop that file (me) - Better Changelog (Greg) Cheers, Peter Peter Rosin (2): iio: resistance: Document that resistance can be output iio: mcp4531: Driver for Microchip digital potentiometers Documentation/ABI/testing/sysfs-bus-iio | 2 + MAINTAINERS | 6 + drivers/iio/Kconfig | 1 + drivers/iio/Makefile | 1 + drivers/iio/potentiometer/Kconfig | 20 +++ drivers/iio/potentiometer/Makefile | 6 + drivers/iio/potentiometer/mcp4531.c | 231 +++++++++++++++++++++++++++++++ 7 files changed, 267 insertions(+) create mode 100644 drivers/iio/potentiometer/Kconfig create mode 100644 drivers/iio/potentiometer/Makefile create mode 100644 drivers/iio/potentiometer/mcp4531.c -- 1.7.10.4 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH v6 0/2] Driver for Microchip digital potentiometers Peter Rosin <peda@lysator.liu.se> - 2015-09-23 16:30 +0200
[PATCH v6 1/2] iio: resistance: Document that resistance can be output Peter Rosin <peda@lysator.liu.se> - 2015-09-23 16:30 +0200
Re: [PATCH v6 1/2] iio: resistance: Document that resistance can be output Jonathan Cameron <jic23@kernel.org> - 2015-09-27 17:50 +0200
[PATCH v6 2/2] iio: mcp4531: Driver for Microchip digital potentiometers Peter Rosin <peda@lysator.liu.se> - 2015-09-23 16:30 +0200
Re: [PATCH v6 2/2] iio: mcp4531: Driver for Microchip digital potentiometers Jonathan Cameron <jic23@kernel.org> - 2015-09-27 18:00 +0200
Re: [PATCH v6 2/2] iio: mcp4531: Driver for Microchip digital potentiometers Peter Rosin <peda@lysator.liu.se> - 2015-09-28 10:10 +0200
Re: [PATCH v6 2/2] iio: mcp4531: Driver for Microchip digital potentiometers Daniel Baluta <daniel.baluta@gmail.com> - 2015-09-28 10:20 +0200
Re: [PATCH v6 2/2] iio: mcp4531: Driver for Microchip digital potentiometers Jonathan Cameron <jic23@kernel.org> - 2015-09-28 23:20 +0200
csiph-web