Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1231017
| Path | csiph.com!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Lee Jones <lee.jones@linaro.org> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] mfd: lpc_ich: Separate device cells for clarity |
| Date | Wed, 23 Sep 2015 00:50:01 +0200 |
| Message-ID | <qbExP-2ia-5@gated-at.bofh.it> (permalink) |
| References | <q4J9g-5BN-11@gated-at.bofh.it> <q4J9g-5BN-9@gated-at.bofh.it> |
| X-Original-To | Aaron Sierra <asierra@xes-inc.com> |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:date:from:to:cc:subject:message-id:references :mime-version:content-type:content-disposition :content-transfer-encoding:in-reply-to:user-agent; bh=E45g6AaDuHOz2dr12CIt53oDrBv0lN1FehFGHbNo8nY=; b=Cp/v50UMU+dis2xuzOLDdS2+vCi1uaWnzifkd4203r6lV/b2K6Fw/POMux7ItjsiMt UzX0wP0OvBcyjlv2WKvZWX3tWZ2/k8+zD6JUkdI22u2hd5kdQomiks3XQWG0z+hmEcVK K9CYxBEmRBo9NzFy+Nf0DIpNKJ0B8AXiVtAEtzSjKVPmqAG3hVYXsGtsHHqdGHsdQX0f bTGQfFunikbYa5jU4QpeyamcwY/Qo22wRdkn/q+n5ssmrgSUm9J9FF9lqSXcC96xmAXt 78UWb/UWc2+7GQvaZafeFDBNYPlshyikpbpPnCsj9mG0BkKaWZfYcm0H5YMuOzokCuLT GNdQ== |
| X-Gm-Message-State | ALoCoQn4is9ehlMSKci2Tz1CTphbHr5FQc7uD1UxbqRqdd2pruvHCqhOcMxxeEMDZ+36vYqUwWQI |
| X-Received | by 10.68.202.9 with SMTP id ke9mr33952935pbc.85.1442961718410; Tue, 22 Sep 2015 15:41:58 -0700 (PDT) |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=utf-8 |
| Content-Disposition | inline |
| Content-Transfer-Encoding | 8bit |
| User-Agent | Mutt/1.5.21 (2010-09-15) |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 124 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | linux-kernel <linux-kernel@vger.kernel.org>, Peter Tyser <ptyser@xes-inc.com>, Guenter Roeck <linux@roeck-us.net>, Jean Delvare <jdelvare@suse.com>, Samuel Ortiz <sameo@linux.intel.com>, Andy Shevchenko <andriy.shevchenko@linux.intel.com>, Mika Westerberg <mika.westerberg@linux.intel.com>, Matt Fleming <matt.fleming@intel.com> |
| X-Original-Date | Tue, 22 Sep 2015 23:41:50 +0100 |
| X-Original-Message-ID | <20150922224150.GE9317@x1> |
| X-Original-References | <665163563.75615.1441306612262.JavaMail.zimbra@xes-inc.com> <1595954137.78926.1441307640528.JavaMail.zimbra@xes-inc.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1231017 |
Show key headers only | View raw
On Thu, 03 Sep 2015, Aaron Sierra wrote:
> The lpc_ich_cells array gives the wrong impression about the
> relationship between the watchdog and GPIO devices. They are
> completely distinct devices, so this patch separates the
> array into distinct mfd_cell structs per device.
>
> A side effect of removing the array, is that the lpc_cells enum
> is no longer needed.
>
> Signed-off-by: Aaron Sierra <asierra@xes-inc.com>
> ---
> drivers/mfd/lpc_ich.c | 42 ++++++++++++++++++------------------------
> 1 file changed, 18 insertions(+), 24 deletions(-)
You need to rebase this. It doesn't apply.
> diff --git a/drivers/mfd/lpc_ich.c b/drivers/mfd/lpc_ich.c
> index 8de3439..7a01d430 100644
> --- a/drivers/mfd/lpc_ich.c
> +++ b/drivers/mfd/lpc_ich.c
> @@ -131,24 +131,18 @@ static struct resource gpio_ich_res[] = {
> },
> };
>
> -enum lpc_cells {
> - LPC_WDT = 0,
> - LPC_GPIO,
> +static struct mfd_cell lpc_ich_wdt_cell = {
> + .name = "iTCO_wdt",
> + .num_resources = ARRAY_SIZE(wdt_ich_res),
> + .resources = wdt_ich_res,
> + .ignore_resource_conflicts = true,
> };
>
> -static struct mfd_cell lpc_ich_cells[] = {
> - [LPC_WDT] = {
> - .name = "iTCO_wdt",
> - .num_resources = ARRAY_SIZE(wdt_ich_res),
> - .resources = wdt_ich_res,
> - .ignore_resource_conflicts = true,
> - },
> - [LPC_GPIO] = {
> - .name = "gpio_ich",
> - .num_resources = ARRAY_SIZE(gpio_ich_res),
> - .resources = gpio_ich_res,
> - .ignore_resource_conflicts = true,
> - },
> +static struct mfd_cell lpc_ich_gpio_cell = {
> + .name = "gpio_ich",
> + .num_resources = ARRAY_SIZE(gpio_ich_res),
> + .resources = gpio_ich_res,
> + .ignore_resource_conflicts = true,
> };
>
> /* chipset related info */
> @@ -881,7 +875,7 @@ static int lpc_ich_init_gpio(struct pci_dev *dev)
> base_addr = base_addr_cfg & 0x0000ff80;
> if (!base_addr) {
> dev_notice(&dev->dev, "I/O space for ACPI uninitialized\n");
> - lpc_ich_cells[LPC_GPIO].num_resources--;
> + lpc_ich_gpio_cell.num_resources--;
> goto gpe0_done;
> }
>
> @@ -895,7 +889,7 @@ static int lpc_ich_init_gpio(struct pci_dev *dev)
> * the platform_device subsystem doesn't see this resource
> * or it will register an invalid region.
> */
> - lpc_ich_cells[LPC_GPIO].num_resources--;
> + lpc_ich_gpio_cell.num_resources--;
> acpi_conflict = true;
> } else {
> lpc_ich_enable_acpi_space(dev);
> @@ -933,14 +927,14 @@ gpe0_done:
> lpc_chipset_info[priv->chipset].use_gpio = ret;
> lpc_ich_enable_gpio_space(dev);
>
> - lpc_ich_finalize_cell(dev, &lpc_ich_cells[LPC_GPIO]);
> + lpc_ich_finalize_cell(dev, &lpc_ich_gpio_cell);
> ret = mfd_add_devices(&dev->dev, PLATFORM_DEVID_AUTO,
> - &lpc_ich_cells[LPC_GPIO], 1, NULL, 0, NULL);
> + &lpc_ich_gpio_cell, 1, NULL, 0, NULL);
>
> gpio_done:
> if (acpi_conflict)
> pr_warn("Resource conflict(s) found affecting %s\n",
> - lpc_ich_cells[LPC_GPIO].name);
> + lpc_ich_gpio_cell.name);
> return ret;
> }
>
> @@ -984,7 +978,7 @@ static int lpc_ich_init_wdt(struct pci_dev *dev)
> */
> if (lpc_chipset_info[priv->chipset].iTCO_version == 1) {
> /* Don't register iomem for TCO ver 1 */
> - lpc_ich_cells[LPC_WDT].num_resources--;
> + lpc_ich_wdt_cell.num_resources--;
> } else if (lpc_chipset_info[priv->chipset].iTCO_version == 2) {
> pci_read_config_dword(dev, RCBABASE, &base_addr_cfg);
> base_addr = base_addr_cfg & 0xffffc000;
> @@ -1007,9 +1001,9 @@ static int lpc_ich_init_wdt(struct pci_dev *dev)
> res->end = base_addr + ACPIBASE_PMC_END;
> }
>
> - lpc_ich_finalize_cell(dev, &lpc_ich_cells[LPC_WDT]);
> + lpc_ich_finalize_cell(dev, &lpc_ich_wdt_cell);
> ret = mfd_add_devices(&dev->dev, PLATFORM_DEVID_AUTO,
> - &lpc_ich_cells[LPC_WDT], 1, NULL, 0, NULL);
> + &lpc_ich_wdt_cell, 1, NULL, 0, NULL);
>
> wdt_done:
> return ret;
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH] mfd: lpc_ich: Separate device cells for clarity Lee Jones <lee.jones@linaro.org> - 2015-09-23 00:50 +0200
csiph-web