Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1326483

Re: [PATCH 1/6] ibmvscsi: Correct values for several viosrp_crq_format enums

From Johannes Thumshirn <jthumshirn@suse.de>
Newsgroups linux.kernel
Subject Re: [PATCH 1/6] ibmvscsi: Correct values for several viosrp_crq_format enums
Date 2016-02-04 09:40 +0100
Message-ID <qYnCi-69d-9@gated-at.bofh.it> (permalink)
References <qYf24-oH-53@gated-at.bofh.it> <qYfbI-uu-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Feb 03, 2016 at 05:28:29PM -0600, Tyrel Datwyler wrote:
> The enum values for VIOSRP_LINUX_FORMAT and VIOSRP_INLINE_FORMAT are
> off by one. They are currently defined as 0x06 and 0x07 respetively.
> These values are defined in PAPR correctly as 0x05 and 0x06. This
> inconsistency has gone unnoticed as neither enum is currently used.
> The possible future support of PING messages between the VIOS and
> client adapter relies on VIOSRP_INLINE_FORMAT crq messages.
> Corrected these enum values to match PAPR definitions.
> 
> Signed-off-by: Tyrel Datwyler <tyreld@linux.vnet.ibm.com>
> ---
>  drivers/scsi/ibmvscsi/viosrp.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/scsi/ibmvscsi/viosrp.h b/drivers/scsi/ibmvscsi/viosrp.h
> index 1162430..d1044e9 100644
> --- a/drivers/scsi/ibmvscsi/viosrp.h
> +++ b/drivers/scsi/ibmvscsi/viosrp.h
> @@ -56,8 +56,8 @@ enum viosrp_crq_formats {
>  	VIOSRP_MAD_FORMAT = 0x02,
>  	VIOSRP_OS400_FORMAT = 0x03,
>  	VIOSRP_AIX_FORMAT = 0x04,
> -	VIOSRP_LINUX_FORMAT = 0x06,
> -	VIOSRP_INLINE_FORMAT = 0x07
> +	VIOSRP_LINUX_FORMAT = 0x05,
> +	VIOSRP_INLINE_FORMAT = 0x06
>  };
>  
>  enum viosrp_crq_status {
> -- 
> 2.5.0
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>
-- 
Johannes Thumshirn                                          Storage
jthumshirn@suse.de                                +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/6] ibmvscsi: code cleanup  Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:30 +0100
  [PATCH 1/6] ibmvscsi: Correct values for several viosrp_crq_format enums Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:40 +0100
    Re: [PATCH 1/6] ibmvscsi: Correct values for several  viosrp_crq_format enums Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-04 09:40 +0100
  [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header values Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:40 +0100
    Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header  values Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-04 09:40 +0100
    Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header  values Manoj Kumar <manoj@linux.vnet.ibm.com> - 2016-02-04 21:00 +0100
      Re: [PATCH 2/6] ibmvscsi: Add and use enums for valid CRQ header  values Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 22:30 +0100
  [PATCH 4/6] ibmvscsi: Use of_root to access OF device tree root node Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:40 +0100
    Re: [PATCH 4/6] ibmvscsi: Use of_root to access OF device tree root  node Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-04 09:50 +0100
  [PATCH 6/6] ibmvscsi: Add endian conversions to sysfs attribute show functions Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:40 +0100
    Re: [PATCH 6/6] ibmvscsi: Add endian conversions to sysfs attribute  show functions Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-04 09:50 +0100
  [PATCH 3/6] ibmvscsi: Replace magic values in set_adpater_info() with defines Tyrel Datwyler <tyreld@linux.vnet.ibm.com> - 2016-02-04 00:40 +0100
    Re: [PATCH 3/6] ibmvscsi: Replace magic values in set_adpater_info()  with defines Johannes Thumshirn <jthumshirn@suse.de> - 2016-02-04 09:50 +0100

csiph-web