Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1324687
| From | Julian Calaby <julian.calaby@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] rtlwifi: Fix reusable codes in core.c |
| Date | 2016-02-02 23:20 +0100 |
| Message-ID | <qXRsK-1hN-5@gated-at.bofh.it> (permalink) |
| References | <qXLnk-55B-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Byeoungwook,
On Wed, Feb 3, 2016 at 2:48 AM, Byeoungwook Kim <quddnr145@gmail.com> wrote:
> rtl_*_delay() functions were reused same codes about addr variable.
> So i have converted to rtl_addr_delay() from code about addr variable.
>
> Conditional codes in rtl_addr_delay() were improved in readability and
> performance by using switch codes.
>
> Signed-off-by: Byeoungwook Kim <quddnr145@gmail.com>
> ---
> drivers/net/wireless/realtek/rtlwifi/core.c | 48 +++++++++++------------------
> 1 file changed, 18 insertions(+), 30 deletions(-)
>
> diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
> index 4ae421e..c1193d1 100644
> --- a/drivers/net/wireless/realtek/rtlwifi/core.c
> +++ b/drivers/net/wireless/realtek/rtlwifi/core.c
> @@ -37,36 +37,34 @@
>
> void rtl_addr_delay(u32 addr)
> {
> - if (addr == 0xfe)
> + switch (addr) {
> + case 0xfe:
> mdelay(50);
> - else if (addr == 0xfd)
> + break;
> + case 0xfd:
> mdelay(5);
> - else if (addr == 0xfc)
> + break;
> + case 0xfc:
> mdelay(1);
> - else if (addr == 0xfb)
> + break;
> + case 0xfb:
> udelay(50);
> - else if (addr == 0xfa)
> + break;
> + case 0xfa:
> udelay(5);
> - else if (addr == 0xf9)
> + break;
> + case 0xf9:
> udelay(1);
> + break;
> + };
As you're introducing a case statement here, you could consolidate the
addresses that have the same delays, i.e.
case 0xfe:
case 0xfb:
mdelay(50);
break;
also, you should arguably be doing this cleanup in a separate patch, i.e.
1. Convert open coded instances to use this function (i.e. the changes
below this comment)
2. Improve the function
> }
> EXPORT_SYMBOL(rtl_addr_delay);
>
> void rtl_rfreg_delay(struct ieee80211_hw *hw, enum radio_path rfpath, u32 addr,
> u32 mask, u32 data)
> {
> - if (addr == 0xfe) {
> - mdelay(50);
> - } else if (addr == 0xfd) {
> - mdelay(5);
> - } else if (addr == 0xfc) {
> - mdelay(1);
> - } else if (addr == 0xfb) {
> - udelay(50);
> - } else if (addr == 0xfa) {
> - udelay(5);
> - } else if (addr == 0xf9) {
> - udelay(1);
> + if (addr >= 0xf9 && addr <= 0xfe) {
> + rtl_addr_delay(addr);
> } else {
> rtl_set_rfreg(hw, rfpath, addr, mask, data);
> udelay(1);
> @@ -76,18 +74,8 @@ EXPORT_SYMBOL(rtl_rfreg_delay);
>
> void rtl_bb_delay(struct ieee80211_hw *hw, u32 addr, u32 data)
> {
> - if (addr == 0xfe) {
> - mdelay(50);
> - } else if (addr == 0xfd) {
> - mdelay(5);
> - } else if (addr == 0xfc) {
> - mdelay(1);
> - } else if (addr == 0xfb) {
> - udelay(50);
> - } else if (addr == 0xfa) {
> - udelay(5);
> - } else if (addr == 0xf9) {
> - udelay(1);
> + if (addr >= 0xf9 && addr <= 0xfe) {
> + rtl_addr_delay(addr);
> } else {
> rtl_set_bbreg(hw, addr, MASKDWORD, data);
> udelay(1);
Thanks,
--
Julian Calaby
Email: julian.calaby@gmail.com
Profile: http://www.google.com/profiles/julian.calaby/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] rtlwifi: Fix reusable codes in core.c Byeoungwook Kim <quddnr145@gmail.com> - 2016-02-02 16:50 +0100
Re: [PATCH] rtlwifi: Fix reusable codes in core.c Julian Calaby <julian.calaby@gmail.com> - 2016-02-02 23:20 +0100
Re: [PATCH] rtlwifi: Fix reusable codes in core.c Julian Calaby <julian.calaby@gmail.com> - 2016-02-03 02:00 +0100
csiph-web