Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1322476
| From | Emil Velikov <emil.l.velikov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 06/10] staging/android: turn fence_info into a __64 pointer |
| Date | 2016-01-30 19:10 +0100 |
| Message-ID | <qWI8a-7MQ-7@gated-at.bofh.it> (permalink) |
| References | <qWoM9-IK-3@gated-at.bofh.it> <qWoMb-IK-31@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Gustavo,
s/__64/__u64/ in the commit message.
On 29 January 2016 at 23:20, Gustavo Padovan <gustavo@padovan.org> wrote:
> From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
>
> Making fence_info a pointer enables us to extend the struct in the future
> without breaking the ABI.
>
> Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> diff --git a/drivers/staging/android/uapi/sync.h b/drivers/staging/android/uapi/sync.h
> index ed281fc..9f07aa7 100644
> --- a/drivers/staging/android/uapi/sync.h
> +++ b/drivers/staging/android/uapi/sync.h
> @@ -54,7 +54,7 @@ struct sync_file_info {
> char name[32];
> __s32 status;
>
> - __u8 fence_info[0];
> + __u64 *fence_info;
I believe you misinterpreted what was meant with "_u64 pointer". As
the storage use for of a pointer varies across 32/64 bit arch, we
explicitly use a variable type that is large enough (and consistent)
for both cases. Thus the above should be
+ __u64 fence_info;
Hope this clarifies things.
-Emil
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/10] android sync framework: clean up IOCTLs and ABI. Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
[PATCH 04/10] staging/android: remove driver_data from struct fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
[PATCH 05/10] staging/android: remove len field from struct fence_info Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
[PATCH 06/10] staging/android: turn fence_info into a __64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
Re: [PATCH 06/10] staging/android: turn fence_info into a __64 pointer Emil Velikov <emil.l.velikov@gmail.com> - 2016-01-30 19:10 +0100
Re: [PATCH 06/10] staging/android: turn fence_info into a __64 pointer Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-01 09:50 +0100
Re: [PATCH 06/10] staging/android: turn fence_info into a __64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-01 19:10 +0100
Re: [PATCH 06/10] staging/android: turn fence_info into a __64 pointer Gustavo Padovan <gustavo@padovan.org> - 2016-02-02 14:10 +0100
[PATCH 01/10] staging/android: remove SYNC_WAIT ioctl Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
[PATCH 08/10] staging/android: rename SYNC_IOC_FENCE_INFO Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
[PATCH 09/10] staging/android: add flags member to sync ioctl structs Gustavo Padovan <gustavo@padovan.org> - 2016-01-29 22:30 +0100
Re: [PATCH 09/10] staging/android: add flags member to sync ioctl structs Emil Velikov <emil.l.velikov@gmail.com> - 2016-01-30 19:20 +0100
Re: [PATCH 09/10] staging/android: add flags member to sync ioctl structs Gustavo Padovan <gustavo@padovan.org> - 2016-02-01 14:30 +0100
Re: [PATCH 09/10] staging/android: add flags member to sync ioctl structs Maarten Lankhorst <maarten.lankhorst@linux.intel.com> - 2016-02-01 09:50 +0100
csiph-web