Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1321479
| From | Andy Gross <andy.gross@linaro.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/4] dmaengine: qcom_bam_dma: use correct pipe FIFO size |
| Date | 2016-01-29 05:40 +0100 |
| Message-ID | <qW90K-5NS-1@gated-at.bofh.it> (permalink) |
| References | (1 earlier) <qAPgm-7I5-21@gated-at.bofh.it> <qAWUy-49J-41@gated-at.bofh.it> <qBiLo-1hG-13@gated-at.bofh.it> <qBjo6-1O1-27@gated-at.bofh.it> <qE9iz-6It-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Thu, Dec 10, 2015 at 03:18:33PM +0200, Stanimir Varbanov wrote: <snip> > >>> This is just using the #define. That is ok, but if you use this instead of the > >>> BAM_P_FIFO_SIZES then you need to fix your comment. Or actually use the > >>> register value.... otherwise looks fine. > >> > >> I did not follow your comment, but the intension of the patch is to set > >> the proper FIFO size in BAM_P_FIFO_SIZES register, i.e. 32K - 8. > > > > Sorry, I mixed up the usage and was thinking there was something you read out > > that told you the size. That's not how it works, unfortunately. The > > MAX_DATA_SIZE is fine, but the name is a little misleading. Perhaps just > > BAM_FIFO_SIZE? > > OK I can rename BAM_MAX_DATA_SIZE to BAM_FIFO_SIZE, and use it when > setting BAM_P_FIFO_SIZES register. Is that fine to you? Yes that's fine with me.
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH 3/4] dmaengine: qcom_bam_dma: use correct pipe FIFO size Andy Gross <andy.gross@linaro.org> - 2016-01-29 05:40 +0100
csiph-web