Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1317479
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH V3 1/2] regulator: Add document for MT6323 regulator |
| Date | 2016-01-26 03:40 +0100 |
| Message-ID | <qV1HY-4RV-17@gated-at.bofh.it> (permalink) |
| References | <qUNYm-3kJ-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jan 25, 2016 at 12:56:28PM +0100, John Crispin wrote:
> Signed-off-by: John Crispin <blogic@openwrt.org>
> Cc: devicetree@vger.kernel.org
> ---
> .../bindings/regulator/mt6323-regulator.txt | 241 ++++++++++++++++++++
> 1 file changed, 241 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/regulator/mt6323-regulator.txt
>
> diff --git a/Documentation/devicetree/bindings/regulator/mt6323-regulator.txt b/Documentation/devicetree/bindings/regulator/mt6323-regulator.txt
> new file mode 100644
> index 0000000..4412102
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/regulator/mt6323-regulator.txt
> @@ -0,0 +1,241 @@
> +Mediatek MT6323 Regulator Driver
> +
> +Required properties:
> +- compatible: "mediatek,mt6323-regulator"
> +- mt6323regulator: List of regulators provided by this controller. It is named
> + according to its regulator type, buck_<name> and ldo_<name>.
> + The definition for each of these nodes is defined using the standard binding
> + for regulators at Documentation/devicetree/bindings/regulator/regulator.txt.
This is a node, not property and it should be named "regulators".
> +
> +The valid names for regulators are::
> +BUCK:
> + buck_vproc, buck_vsys, buck_vpa
> +LDO:
> + ldo_vtcxo, ldo_vcn28, ldo_vcn33_bt, ldo_vcn33_wifi, ldo_va, ldo_vcama,
> + ldo_vio28, ldo_vusb, ldo_vmc, ldo_vmch, ldo_vemc3v3, ldo_vgp1, ldo_vgp2,
> + ldo_vgp3, ldo_vcn18, ldo_vsim1, ldo_vsim2, ldo_vrtc, ldo_vcamaf, ldo_vibr,
> + ldo_vrf18, ldo_vm, ldo_vio18, ldo_vcamd, ldo_vcamio
> +
> +Example:
> +
> + pmic: mt6323 {
> + compatible = "mediatek,mt6323";
> +
> + mt6323regulator: mt6323regulator{
> + compatible = "mediatek,mt6323-regulator";
> +
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH V3 1/2] regulator: Add document for MT6323 regulator John Crispin <blogic@openwrt.org> - 2016-01-25 13:00 +0100 Re: [PATCH V3 1/2] regulator: Add document for MT6323 regulator Rob Herring <robh@kernel.org> - 2016-01-26 03:40 +0100
csiph-web