Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1316961

Re: [PATCH v2 00/10] rtc: max77686: Extend driver and add max77802 support

From Alexandre Belloni <alexandre.belloni@free-electrons.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 00/10] rtc: max77686: Extend driver and add max77802 support
Date 2016-01-25 17:30 +0100
Message-ID <qUSbE-6CP-27@gated-at.bofh.it> (permalink)
References <qTu1H-1V0-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

On 21/01/2016 at 17:23:23 -0300, Javier Martinez Canillas wrote :
> On a recent disussion [0] with Krzysztof Kozlowski and Laxman Dewangan,
> we came to the conclusion that the max77686 and max77802 RTC are almost
> the same with only a few differences so there shouldn't be two separate
> drivers and is better to extend max77686 driver and delete rtc-max77802.
> 
> By making the driver more generic, other RTC IP blocks from Maxim PMICs
> could be supported as well like the max77620.
> 
> This is a v2 of a series that do this, that address issues pointed out
> by Krzysztof Kozlowski. The v1 can be found at [1].
> 
> I've tested this patch-set on an Exynos5800 Peach Pi Chromebook that has
> a max77802 PMIC and the RTC was working correctly but I don't have a
> machine with max77686 so I will really appreaciate if someone can test
> that no regressions were introduced.
> 
> On an IRC conversation, Alexandre suggested to use the field support in
> the regmap API to avoid needing a translation table. I spent some time
> to look at it and I'm not so sure if it fits that well in this case.
> 
> It's true that we could model each register as if it has a single field
> and provide a different reg address but I'm not sure if that would make
> things more clear or cause more confusion for future code archaeologists.
> 

Yeah, Mark suggested that regmap_field may be what we were looking for
but I'm not convinced it really fits.

> In any case, I think this series are a move in the right direction since
> removes code duplication and a complete driver and also allows others to
> reuse the driver for another RTC chip. We can later simplify and use the
> regmap field API or extend the regmap core if that could make things even
> simpler but I propose to do it as a follow up.
> 

I don't have any objection or other comment on that series. So
basically, I'm waiting for v3 and I'll apply it.


-- 
Alexandre Belloni, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 00/10] rtc: max77686: Extend driver and add max77802 support Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
  [PATCH v2 01/10] rtc: max77686: Fix max77686_rtc_read_alarm() return value Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
    Re: [PATCH v2 01/10] rtc: max77686: Fix max77686_rtc_read_alarm()  return value Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-01-22 02:00 +0100
    Re: [PATCH v2 01/10] rtc: max77686: Fix max77686_rtc_read_alarm()  return value Laxman Dewangan <ldewangan@nvidia.com> - 2016-01-22 10:50 +0100
  [PATCH v2 02/10] rtc: max77686: Use ARRAY_SIZE() instead of current array length Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
    Re: [PATCH v2 02/10] rtc: max77686: Use ARRAY_SIZE() instead of  current array length Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-01-22 02:00 +0100
    Re: [PATCH v2 02/10] rtc: max77686: Use ARRAY_SIZE() instead of current  array length Laxman Dewangan <ldewangan@nvidia.com> - 2016-01-22 11:00 +0100
      Re: [PATCH v2 02/10] rtc: max77686: Use ARRAY_SIZE() instead of  current array length Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-22 12:50 +0100
  [PATCH v2 07/10] rtc: max77686: Use dev_warn() instead of pr_warn() Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
  [PATCH v2 03/10] rtc: max77686: Use usleep_range() instead of msleep() Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
    Re: [PATCH v2 03/10] rtc: max77686: Use usleep_range() instead of  msleep() Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2016-01-22 02:10 +0100
    Re: [PATCH v2 03/10] rtc: max77686: Use usleep_range() instead of  msleep() Laxman Dewangan <ldewangan@nvidia.com> - 2016-01-22 11:00 +0100
      Re: [PATCH v2 03/10] rtc: max77686: Use usleep_range() instead of  msleep() Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-22 13:10 +0100
        Re: [PATCH v2 03/10] rtc: max77686: Use usleep_range() instead of  msleep() Laxman Dewangan <ldewangan@nvidia.com> - 2016-01-25 12:30 +0100
  [PATCH v2 10/10] ARM: multi_v7_defconfig: Remove MAX77802 RTC Kconfig symbol Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
    Re: [PATCH v2 10/10] ARM: multi_v7_defconfig: Remove MAX77802 RTC  Kconfig symbol Laxman Dewangan <ldewangan@nvidia.com> - 2016-01-22 11:10 +0100
      Re: [PATCH v2 10/10] ARM: multi_v7_defconfig: Remove MAX77802 RTC  Kconfig symbol Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-22 13:10 +0100
  [PATCH v2 09/10] ARM: exynos_defconfig: Remove MAX77802 RTC Kconfig symbol Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-21 21:30 +0100
  Re: [PATCH v2 00/10] rtc: max77686: Extend driver and add max77802  support Alexandre Belloni <alexandre.belloni@free-electrons.com> - 2016-01-25 17:30 +0100
    Re: [PATCH v2 00/10] rtc: max77686: Extend driver and add max77802  support Javier Martinez Canillas <javier@osg.samsung.com> - 2016-01-26 00:50 +0100

csiph-web