Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1314313

[PATCH 01/16] perf tests: Remove wrong semicolon in while loop in CQM test

From Arnaldo Carvalho de Melo <acme@kernel.org>
Newsgroups linux.kernel
Subject [PATCH 01/16] perf tests: Remove wrong semicolon in while loop in CQM test
Date 2016-01-21 17:10 +0100
Message-ID <qTpY7-7Ez-43@gated-at.bofh.it> (permalink)
References <qTpY5-7Ez-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Markus Trippelsdorf <markus@trippelsdorf.de>

The while loop was spinning. Fix by removing a semicolon.

The issue was pointed out by gcc-6's -Wmisleading-indentation.

Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
Reviewed-by: Matt Fleming <matt@codeblueprint.co.uk>
Acked-by: Ingo Molnar <mingo@kernel.org>
Cc: Ben Hutchings <ben@decadent.org.uk>
Cc: Peter Zijlstra <peterz@infradead.org>
Fixes: 035827e9f2bd ("perf tests: Add Intel CQM test")
Link: http://lkml.kernel.org/r/20151214154335.GA1409@x4
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
 tools/perf/arch/x86/tests/intel-cqm.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tools/perf/arch/x86/tests/intel-cqm.c b/tools/perf/arch/x86/tests/intel-cqm.c
index 3e89ba825f6b..7f064eb37158 100644
--- a/tools/perf/arch/x86/tests/intel-cqm.c
+++ b/tools/perf/arch/x86/tests/intel-cqm.c
@@ -17,7 +17,7 @@ static pid_t spawn(void)
 	if (pid)
 		return pid;
 
-	while(1);
+	while(1)
 		sleep(5);
 	return 0;
 }
-- 
2.5.0

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[GIT PULL 00/16] perf/core improvements and changes Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-01-21 17:10 +0100
  [PATCH 06/16] perf stat: Do not clean event's private stats Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-01-21 17:10 +0100
  [PATCH 01/16] perf tests: Remove wrong semicolon in while loop in CQM test Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-01-21 17:10 +0100
  [PATCH 11/16] perf annotate: Rename 'colors.code' to 'colors.jump_arrows' Arnaldo Carvalho de Melo <acme@kernel.org> - 2016-01-21 17:10 +0100

csiph-web