Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1315342

Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code

From Boris Ostrovsky <boris.ostrovsky@oracle.com>
Newsgroups linux.kernel
Subject Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code
Date 2016-01-23 00:20 +0100
Message-ID <qTT9M-2wH-9@gated-at.bofh.it> (permalink)
References <qTRB0-1oj-3@gated-at.bofh.it> <qTRB0-1oj-13@gated-at.bofh.it> <qTT06-2t8-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 01/22/2016 06:01 PM, Luis R. Rodriguez wrote:
> On Fri, Jan 22, 2016 at 04:35:48PM -0500, Boris Ostrovsky wrote:
>> HVMlite guests (to be introduced in subsequent patches) share most
>> of the kernel initialization code with PV(H).
>>
>> Signed-off-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
>> ---
>>   arch/x86/xen/enlighten.c |  225 ++++++++++++++++++++++++----------------------
>>   1 files changed, 119 insertions(+), 106 deletions(-)
>>
>> diff --git a/arch/x86/xen/enlighten.c b/arch/x86/xen/enlighten.c
>> index d09e4c9..2cf446a 100644
>> --- a/arch/x86/xen/enlighten.c
>> +++ b/arch/x86/xen/enlighten.c
> Whoa, I'm lost, its hard for me to tell what exactly stayed and what
> got pulled into a helper, etc. Is there a possibility to split this
> patch in 2 somehow to make the actual functional changes easier to
> read? There are too many changes here and I just can't tell easily
> what's going on.


The only real changes that this patch introduces is it reorders some of 
the operations that used to be in xen_start_kernel(). This is done so 
that in the next patch when we add hvmlite we can easily put those 
specific to PV(H) inside 'if (!xen_hvm_domain())'. I probably should 
have said so in the commit message.

It is indeed difficult to review but I don't see how I can split this. 
Even if I just moved it (without reordering) it would still be hard to read.

-boris

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-01-22 22:40 +0100
  Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-01-23 00:10 +0100
    Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-01-23 00:20 +0100
      Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-01-23 00:30 +0100
      Re: [PATCH v1 02/12] xen/hvmlite: Factor out common kernel init code "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-01-23 00:50 +0100
  Re: [Xen-devel] [PATCH v1 02/12] xen/hvmlite: Factor out common  kernel init code David Vrabel <david.vrabel@citrix.com> - 2016-01-25 12:10 +0100
    Re: [Xen-devel] [PATCH v1 02/12] xen/hvmlite: Factor out common  kernel init code Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-01-25 16:50 +0100

csiph-web