Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1313257

Re: [PATCH v2] can: c_can: add xceiver enable/disable support

From Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be>
Newsgroups linux.kernel
Subject Re: [PATCH v2] can: c_can: add xceiver enable/disable support
Date 2016-01-20 15:40 +0100
Message-ID <qT1VN-7Ky-19@gated-at.bofh.it> (permalink)
References <qT1j4-7c8-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


> diff --git a/drivers/net/can/c_can/c_can.c b/drivers/net/can/c_can/c_can.c
> index f91b094..0723aeb 100644
> --- a/drivers/net/can/c_can/c_can.c
> +++ b/drivers/net/can/c_can/c_can.c
> @@ -1263,6 +1271,10 @@ int register_c_can_dev(struct net_device *dev)
>  	 */
>  	pinctrl_pm_select_sleep_state(dev->dev.parent);
>  
> +	priv->reg_xceiver = devm_regulator_get(priv->device, "xceiver");

I assume "xceiver" is the shorter name for "transceiver"?
In that case, I suggest changing the devicetree label to "transceiver".
It would become a mess if different drivers use different names.
I see no real benefit for naming it "xceiver". "trx" is even shorter :-)
See also http://www.acronymfinder.com/TRX.html

The internals, like variable names, do not really matter here.

I haven't looked at other driver, yet the argument still stands.

Kind regards,
Kurt

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2] can: c_can: add xceiver enable/disable support Michael Grzeschik <m.grzeschik@pengutronix.de> - 2016-01-20 14:50 +0100
  Re: [PATCH v2] can: c_can: add xceiver enable/disable support Markus Pargmann <mpa@pengutronix.de> - 2016-01-20 15:10 +0100
  Re: [PATCH v2] can: c_can: add xceiver enable/disable support Marc Kleine-Budde <mkl@pengutronix.de> - 2016-01-20 15:30 +0100
  Re: [PATCH v2] can: c_can: add xceiver enable/disable support Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be> - 2016-01-20 15:40 +0100
    Re: [PATCH v2] can: c_can: add xceiver enable/disable support Markus Pargmann <mpa@pengutronix.de> - 2016-01-20 15:40 +0100
  Re: [PATCH v2] can: c_can: add xceiver enable/disable support Bjørn Mork <bjorn@mork.no> - 2016-01-20 17:20 +0100
    Re: [PATCH v2] can: c_can: add xceiver enable/disable support Michael Grzeschik <mgr@pengutronix.de> - 2016-01-20 17:50 +0100

csiph-web