Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1306383
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 |
| Date | 2016-01-11 16:20 +0100 |
| Message-ID | <qPMqd-46s-11@gated-at.bofh.it> (permalink) |
| References | <qIBge-8do-3@gated-at.bofh.it> <qPJVn-2ov-5@gated-at.bofh.it> <qPLNw-3Dk-19@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Borislav Petkov <bp@alien8.de> wrote: > On Mon, Jan 11, 2016 at 01:39:44PM +0100, Ingo Molnar wrote: > > So it is only now that I noticed that we have both 'core.c' and 'uncore.c', which > > is slightly bit confusing: the core.c's we have around the kernel denote core > > subsystem functionality - not CPU core functionality. If we have uncore.c around, > > confusion might ensue. > > > > OTOH maybe it's not a big issue and we can just live with it. I'd hate to see > > main.c. Maybe rename 'uncore.c' to 'cpu_uncore.c'? OTOH that sounds a bit silly > > too. So maybe leave it as you named them. > > Well, not doung anything should be ok because the *uncore* things would > go to the <vendor>/ subdir: > > I.e., > > arch/x86/kernel/cpu/perf_event_amd_uncore.c > arch/x86/kernel/cpu/perf_event_intel_uncore.c > arch/x86/kernel/cpu/perf_event_intel_uncore.h > arch/x86/kernel/cpu/perf_event_intel_uncore_nhmex.c > arch/x86/kernel/cpu/perf_event_intel_uncore_snb.c > arch/x86/kernel/cpu/perf_event_intel_uncore_snbep.c > > will become > > arch/x86/events/amd/uncore.c > arch/x86/events/intel/uncore.c > arch/x86/events/intel/uncore.h > arch/x86/events/intel/uncore_nhmex.c > arch/x86/events/intel/uncore_snb.c > arch/x86/events/intel/uncore_snbep.c > > and core.c will be in the upper dir arch/x86/events/ Ok, works for me. Got confused by your ascii art: arch/x86/events/ |-- amd | |-- core.c | |-- ibs.c | |-- iommu.c | |-- iommu.h | `-- uncore.c |-- core.c `-- Makefile which lists events/amd/core.c. Thanks, Ingo
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 Ingo Molnar <mingo@kernel.org> - 2016-01-11 13:40 +0100
Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 Borislav Petkov <bp@alien8.de> - 2016-01-11 15:40 +0100
Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 Ingo Molnar <mingo@kernel.org> - 2016-01-11 16:20 +0100
Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 Borislav Petkov <bp@alien8.de> - 2016-01-11 17:40 +0100
Re: [RFC PATCH 0/5] perf: Sanitize perf directory structure, p1 Ingo Molnar <mingo@kernel.org> - 2016-01-12 12:20 +0100
csiph-web