Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1304255
| From | taeung <treeze.taeung@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH RESEND] perf config: Rename 'colors.code' to 'colors.jump_arrows' |
| Date | 2016-01-08 09:20 +0100 |
| Message-ID | <qOAr8-413-7@gated-at.bofh.it> (permalink) |
| References | <qOcyu-4if-9@gated-at.bofh.it> <qOdNU-5ly-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi, Namhyung
Thanks for your review.
I rechecked this patch and then I found missed part
that is contained on Documentation/perf-config.txt.
So, I'll resend modified patch.
Thanks,
Taeung
On 01/07/2016 05:02 PM, Namhyung Kim wrote:
> On Thu, Jan 07, 2016 at 03:48:10PM +0900, Taeung Song wrote:
>> Suggest 'jump_arrows' config name instead of 'code'
>> on 'colors' section. 'colors.code' config is only for
>> jump arrows on assembly code listings i.e.
>>
>> │ ┌──jmp 1333
>> │ │ xchg %ax,%ax
>> │ │ mov %r15,%r10
>> │ └─→cmp %r15,%r14
>>
>> But this config name seems unfit.
>> Maybe 'jump_arrows' would be better than 'code'.
>>
>> Cc: Jiri Olsa <jolsa@redhat.com>
>> Signed-off-by: Taeung Song <treeze.taeung@gmail.com>
>
> Acked-by: Namhyung Kim <namhyung@kernel.org>
>
> Thanks,
> Namhyung
>
>
>> ---
>> tools/perf/Documentation/perfconfig.example | 2 +-
>> tools/perf/ui/browser.c | 4 ++--
>> tools/perf/ui/browser.h | 2 +-
>> tools/perf/ui/browsers/annotate.c | 2 +-
>> 4 files changed, 5 insertions(+), 5 deletions(-)
>>
>> diff --git a/tools/perf/Documentation/perfconfig.example b/tools/perf/Documentation/perfconfig.example
>> index 767ea24..1d8d5bc 100644
>> --- a/tools/perf/Documentation/perfconfig.example
>> +++ b/tools/perf/Documentation/perfconfig.example
>> @@ -5,7 +5,7 @@
>> medium = green, lightgray
>> normal = black, lightgray
>> selected = lightgray, magenta
>> - code = blue, lightgray
>> + jump_arrows = blue, lightgray
>> addr = magenta, lightgray
>>
>> [tui]
>> diff --git a/tools/perf/ui/browser.c b/tools/perf/ui/browser.c
>> index d372021..af68a9d 100644
>> --- a/tools/perf/ui/browser.c
>> +++ b/tools/perf/ui/browser.c
>> @@ -531,8 +531,8 @@ static struct ui_browser_colorset {
>> .bg = "yellow",
>> },
>> {
>> - .colorset = HE_COLORSET_CODE,
>> - .name = "code",
>> + .colorset = HE_COLORSET_JUMP_ARROWS,
>> + .name = "jump_arrows",
>> .fg = "blue",
>> .bg = "default",
>> },
>> diff --git a/tools/perf/ui/browser.h b/tools/perf/ui/browser.h
>> index 01781de..be3b70e 100644
>> --- a/tools/perf/ui/browser.h
>> +++ b/tools/perf/ui/browser.h
>> @@ -7,7 +7,7 @@
>> #define HE_COLORSET_MEDIUM 51
>> #define HE_COLORSET_NORMAL 52
>> #define HE_COLORSET_SELECTED 53
>> -#define HE_COLORSET_CODE 54
>> +#define HE_COLORSET_JUMP_ARROWS 54
>> #define HE_COLORSET_ADDR 55
>> #define HE_COLORSET_ROOT 56
>>
>> diff --git a/tools/perf/ui/browsers/annotate.c b/tools/perf/ui/browsers/annotate.c
>> index d4d7cc2..d2d2599 100644
>> --- a/tools/perf/ui/browsers/annotate.c
>> +++ b/tools/perf/ui/browsers/annotate.c
>> @@ -284,7 +284,7 @@ static void annotate_browser__draw_current_jump(struct ui_browser *browser)
>> to = (u64)btarget->idx;
>> }
>>
>> - ui_browser__set_color(browser, HE_COLORSET_CODE);
>> + ui_browser__set_color(browser, HE_COLORSET_JUMP_ARROWS);
>> __ui_browser__line_arrow(browser, pcnt_width + 2 + ab->addr_width,
>> from, to);
>> }
>> --
>> 2.5.0
>>
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH RESEND] perf config: Rename 'colors.code' to 'colors.jump_arrows' Taeung Song <treeze.taeung@gmail.com> - 2016-01-07 07:50 +0100
Re: [PATCH RESEND] perf config: Rename 'colors.code' to 'colors.jump_arrows' Namhyung Kim <namhyung@kernel.org> - 2016-01-07 09:10 +0100
Re: [PATCH RESEND] perf config: Rename 'colors.code' to 'colors.jump_arrows' taeung <treeze.taeung@gmail.com> - 2016-01-08 09:20 +0100
csiph-web