Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1301725
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 |
| Date | 2016-01-05 18:30 +0100 |
| Message-ID | <qNDAK-5X5-7@gated-at.bofh.it> (permalink) |
| References | <qNk54-8oP-13@gated-at.bofh.it> <qNk54-8oP-15@gated-at.bofh.it> <qNk54-8oP-11@gated-at.bofh.it> <qNky7-oU-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jan 04, 2016 at 04:01:05PM -0500, Chris Metcalf wrote: > On 01/04/2016 03:33 PM, Mark Rutland wrote: > >Hi, > > > >On Mon, Jan 04, 2016 at 02:34:46PM -0500, Chris Metcalf wrote: > >>This change is a prerequisite change for TASK_ISOLATION but also > >>stands on its own for readability and maintainability. > >I have also been looking into converting the userspace return path from > >assembly to C [1], for the latter two reasons. Based on that, I have a > >couple of comments. > > Thanks! > > >It seems unfortunate to leave behind portions of the entry.S > >_TIF_WORK_MASK state machine (i.e. a small portion of ret_fast_syscall, > >and the majority of work_pending and ret_to_user). > > > >I think it would be nicer if we could handle all of that in one place > >(or at least all in C). > > Yes, in principle I agree with this, and I think your deasm tree looks > like an excellent idea. > > For this patch series I wanted to focus more on what was necessary > for the various platforms to implement task isolation, and less on > additional cleanups of the platforms in question. I think my changes > don't make the TIF state machine any less clear, nor do they make > it harder for an eventual further migration to C code along the lines > of what you've done, so it seems plausible to me to commit them > upstream independently of your work. I appreciate that you don't want to rewrite all the code. However, I think it's easier to factor out a small amount of additional code now and evlove that as a whole than it will be to evolve part of it and try to put it back together later. I have a patch which I will reply with momentarily. Thanks, Mark. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 Mark Rutland <mark.rutland@arm.com> - 2016-01-04 21:40 +0100
Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 Chris Metcalf <cmetcalf@ezchip.com> - 2016-01-04 22:10 +0100
Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 Mark Rutland <mark.rutland@arm.com> - 2016-01-05 18:30 +0100
[PATCH 2/2] arm64: factor work_pending state machine to C Mark Rutland <mark.rutland@arm.com> - 2016-01-05 18:40 +0100
Re: [PATCH 2/2] arm64: factor work_pending state machine to C Chris Metcalf <cmetcalf@ezchip.com> - 2016-01-05 20:00 +0100
Re: [PATCH 2/2] arm64: factor work_pending state machine to C Catalin Marinas <catalin.marinas@arm.com> - 2016-01-06 13:40 +0100
Re: [PATCH 2/2] arm64: factor work_pending state machine to C Mark Rutland <mark.rutland@arm.com> - 2016-01-06 13:50 +0100
Re: [PATCH 2/2] arm64: factor work_pending state machine to C Mark Rutland <mark.rutland@arm.com> - 2016-01-06 14:50 +0100
Re: [PATCH 2/2] arm64: factor work_pending state machine to C Catalin Marinas <catalin.marinas@arm.com> - 2016-01-06 15:20 +0100
[PATCH 1/2] arm64: entry: remove pointless SPSR mode check Mark Rutland <mark.rutland@arm.com> - 2016-01-05 18:40 +0100
Re: [PATCH 1/2] arm64: entry: remove pointless SPSR mode check Catalin Marinas <catalin.marinas@arm.com> - 2016-01-06 13:20 +0100
Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 Andy Lutomirski <luto@amacapital.net> - 2016-01-04 23:40 +0100
Re: [PATCH v9 08/13] arch/arm64: adopt prepare_exit_to_usermode() model from x86 Mark Rutland <mark.rutland@arm.com> - 2016-01-05 19:10 +0100
csiph-web