Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1300032
| From | Mike Danese <mikedanese@google.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] net: refactor icmp_global_allow to improve readability and performance. |
| Date | 2016-01-02 04:30 +0100 |
| Message-ID | <qMl3b-2OF-3@gated-at.bofh.it> (permalink) |
| References | <qM2MW-7kN-3@gated-at.bofh.it> <qMgZA-jl-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Yes, I completely missed the purpose of that. As a new year's
resolution, I resolve to read the comments.
Thanks for the review!
On Fri, Jan 1, 2016 at 3:07 PM, Eric Dumazet <eric.dumazet@gmail.com> wrote:
> On Thu, 2015-12-31 at 23:58 -0800, Mike Danese wrote:
>> We can reduce the number of operations performed by icmp_global_allow
>> and make the routine more readable by refactoring it in two ways:
>>
>> First, this patch refactors the meaning of the "delta" variable. Before
>> this change, it meant min("time since last refill of token bucket", HZ).
>> After this change, it means "time since last refill". The original
>> definition is required only once but was being calculated twice. The new
>> meaning is also more intuitive for a variable named "delta".
>>
>> Second, by calculating "delta" (time since last refill of token bucket)
>> and "cbr" (token bucket can be refilled) at the beginning of the
>> routine, we reduce the number of repeated calculations of these two
>> variables.
>>
>> There should be no functional difference.
>>
>> Signed-off-by: Mike Danese <mikedanese@google.com>
>> ---
>> net/ipv4/icmp.c | 17 ++++++++---------
>> 1 file changed, 8 insertions(+), 9 deletions(-)
>
> Hi Mike
>
> Sorry, this is a very broken patch.
>
> There is a comment you apparently missed completely :
>
> /* Check if token bucket is empty and cannot be refilled
> * without taking the spinlock.
> */
>
> There is a reason we compute 'delta' two times.
>
> One without the spinlock held, and a second time with the spinlock held.
>
> This is an opportunistic way to exit early without false sharing in the
> stress case where many cpus might enter this code.
>
> Really I do not think current code needs any 'refactoring', especially
> around December 31th at midnight ;)
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] net: refactor icmp_global_allow to improve readability and performance. Mike Danese <mikedanese@google.com> - 2016-01-01 09:00 +0100
Re: [PATCH] net: refactor icmp_global_allow to improve readability and performance. Eric Dumazet <eric.dumazet@gmail.com> - 2016-01-02 00:10 +0100
Re: [PATCH] net: refactor icmp_global_allow to improve readability and performance. Mike Danese <mikedanese@google.com> - 2016-01-02 04:30 +0100
csiph-web