Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1291829
| From | Sanidhya Solanki <jpage.lkml@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. |
| Date | 2015-12-15 05:10 +0100 |
| Message-ID | <qFP62-7p3-19@gated-at.bofh.it> (permalink) |
| References | <qDk6m-79U-3@gated-at.bofh.it> <qDqbM-2Nk-27@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
The original code defined macros in the source code, making it
harder to read. Moved them to the header file, as per the TODO file.
Updated the TODO file.
Signed-off-by: Sanidhya Solanki <jpage.lkml@gmail.com>
---
drivers/staging/skein/TODO | 1 -
drivers/staging/skein/skein_block.c | 6 ------
drivers/staging/skein/skein_block.h | 7 +++++++
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/skein/TODO b/drivers/staging/skein/TODO
index cd3508d..e3de0c7 100644
--- a/drivers/staging/skein/TODO
+++ b/drivers/staging/skein/TODO
@@ -1,6 +1,5 @@
skein/threefish TODO
- - move macros into appropriate header files
- add / pass test vectors
- module support
diff --git a/drivers/staging/skein/skein_block.c b/drivers/staging/skein/skein_block.c
index 45b4732..2120392 100644
--- a/drivers/staging/skein/skein_block.c
+++ b/drivers/staging/skein/skein_block.c
@@ -26,12 +26,6 @@
#define SKEIN_LOOP 001 /* default: unroll 256 and 512, but not 1024 */
#endif
-#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
-#define KW_TWK_BASE (0)
-#define KW_KEY_BASE (3)
-#define ks (kw + KW_KEY_BASE)
-#define ts (kw + KW_TWK_BASE)
-
#ifdef SKEIN_DEBUG
#define debug_save_tweak(ctx) \
{ \
diff --git a/drivers/staging/skein/skein_block.h b/drivers/staging/skein/skein_block.h
index 9d40f4a..0fd4bfe 100644
--- a/drivers/staging/skein/skein_block.h
+++ b/drivers/staging/skein/skein_block.h
@@ -7,6 +7,13 @@
** This algorithm and source code is released to the public domain.
**
************************************************************************/
+
+#define BLK_BITS (WCNT * 64) /* some useful definitions for code here */
+#define KW_TWK_BASE (0)
+#define KW_KEY_BASE (3)
+#define ks (kw + KW_KEY_BASE)
+#define ts (kw + KW_TWK_BASE)
+
#ifndef _SKEIN_BLOCK_H_
#define _SKEIN_BLOCK_H_
--
2.5.0
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Sanidhya Solanki <jpage.lkml@gmail.com> - 2015-12-15 05:10 +0100
Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Mathieu Poirier <mathieu.poirier@linaro.org> - 2015-12-15 16:00 +0100
Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Sanidhya Solanki <jpage.lkml@gmail.com> - 2015-12-16 03:30 +0100
Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file. Sudip Mukherjee <sudipm.mukherjee@gmail.com> - 2015-12-17 08:20 +0100
csiph-web