Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1291348

Re: [PATCH] ftrace: Kill ftrace_caller_end label

From Borislav Petkov <bp@alien8.de>
Newsgroups linux.kernel
Subject Re: [PATCH] ftrace: Kill ftrace_caller_end label
Date 2015-12-14 17:50 +0100
Message-ID <qFEtZ-di-29@gated-at.bofh.it> (permalink)
References <qFDRg-8pJ-19@gated-at.bofh.it> <qFEkh-9n-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Dec 14, 2015 at 11:30:27AM -0500, Steven Rostedt wrote:
> On Mon, 14 Dec 2015 17:08:34 +0100
> Borislav Petkov <bp@alien8.de> wrote:
> 
> > From: Borislav Petkov <bp@suse.de>
> > 
> > One of ftrace_caller_and and ftrace_return is redundant so unify them.
> 
> s/_and/_end/

Whoops.

> > Rename ftrace_return to ftrace_epilogue to mean that everything after
> > that label represents, like an afterword, work which happens *after* the
> > ftrace call, e.g., the function graph tracer for one.
> > 
> > Beef up the comment about the code contents and layout before
> > ftrace_epilogue label.
> 
> According to http://www.thefreedictionary.com/epilog
> 
> ep·i·logue also ep·i·log  (ĕp′ə-lôg′, -lŏg′) (n).
> 1.
>    a. A short poem or speech spoken directly to the audience following
>    the conclusion of a play.
> 
> Hmm, that doesn't fit.

Huh, why doesn't that fit?

"A short code executed following the conclusion of a trampoline..." :-)

>    b. The performer who delivers such a short poem or speech.
> 
> Maybe people can think ftrace as a poem. But people will never think
> that I give such a short speech.

LOL.

> 2. A short addition or concluding section at the end of a literary
>    work, often dealing with the future of its characters. Also called
>    afterword.
> 
> Ah, "afterword" also doesn't fit, unless you mean "characters" as a set
> of "char []". Which I guess the trampoline would fit.
> 
> 3. An event which reflects meaningfully on a recently ended conflict or
>    struggle.
> 
> Ah! This looks like the best match! Thus, this should be stated in the
> changelog!

It is simply supposed to denote "stuff done after". You can call it
ftrace_post_work, ftrace_after, ...

I'm sure you're going to fix it up as you like it when applying :-)

Thanks!

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH] ftrace: Kill ftrace_caller_end label Borislav Petkov <bp@alien8.de> - 2015-12-14 17:10 +0100
  Re: [PATCH] ftrace: Kill ftrace_caller_end label Steven Rostedt <rostedt@goodmis.org> - 2015-12-14 17:40 +0100
    Re: [PATCH] ftrace: Kill ftrace_caller_end label Borislav Petkov <bp@alien8.de> - 2015-12-14 17:50 +0100

csiph-web