Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1290514

Re: [PATCH 04/13] lib/vsprintf.c: expand field_width to 24 bits

From Andy Shevchenko <andy.shevchenko@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 04/13] lib/vsprintf.c: expand field_width to 24 bits
Date 2015-12-13 01:50 +0100
Message-ID <qF31o-18c-1@gated-at.bofh.it> (permalink)
References <qlLRn-6h1-3@gated-at.bofh.it> <qlLRo-6h1-27@gated-at.bofh.it> <qB2GD-7Ot-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Wed, Dec 2, 2015 at 1:38 AM, Andrew Morton <akpm@linux-foundation.org> wrote:
> On Tue, 20 Oct 2015 22:30:04 +0200 Rasmus Villemoes <linux@rasmusvillemoes.dk> wrote:
>
>> I didn't find a BUILD_BUG/compiletime_assertion/... which would work
>> outside function context, so for now I just open-coded it.
>>
>
> It comes up occasionally.  It would be better to create one.
>
>> +extern char __check_printf_spec[1-2*(sizeof(struct printf_spec) != 8)];
>
> Maybe something like
>
> /*
>  * Description goes here
>  */
> #define BUILD_BUG_ON_STATIC(unique_id, expr)            \
>         typedef char unique_id[1-2*(expr)];

Yeah, it would be really nice to get rid of unique_id, though I have
no idea how to achieve.

>
> BUILD_BUG_ON_STATIC(__check_printf_spec, sizeof(struct printf_spec) != 8);
>
> ("static" seems the wrong term, but what is the correct term for
> "outside of functions"?)

Just _EXT?  Or _VAR?


-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH 04/13] lib/vsprintf.c: expand field_width to 24 bits Andy Shevchenko <andy.shevchenko@gmail.com> - 2015-12-13 01:50 +0100

csiph-web