Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1286361

[RFC PATCH 0/3] debugfs: implement 'debugfs_create_dir_with_tmpfiles()'

Path csiph.com!news.mixmin.net!weretis.net!feeder1.news.weretis.net!newsfeed.CARNet.hr!news.spin.it!bofh.it!news.nic.it!robomod
From Roman Pen <r.peniaev@gmail.com>
Newsgroups linux.kernel
Subject [RFC PATCH 0/3] debugfs: implement 'debugfs_create_dir_with_tmpfiles()'
Date Tue, 08 Dec 2015 11:00:03 +0100
Message-ID <qDndU-AW-5@gated-at.bofh.it> (permalink)
X-Original-To unlisted-recipients:; (no To-header on input)
Dkim-Signature v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=from:to:cc:subject:date:message-id; bh=QZk+4XV169PVOnufYPiorFZlQrhks4RvjtMwc8fKmfA=; b=Ex3LD4hjVtbd/+JyeD7hhRoebhCHOv+/PEE5+cyTpHkJX6sQo16aE8V7d5TF9srEEZ 2GCW25nqpYCH/HjwXfkRMEwEiTEbqZTmujVG5LW8hSC1IJmh2aCwaiiwEcWvTukRyw9N QzcxyOtSlYuwTD3Ejbw8c7Pyry02XgcwhQNgQtZJ2e2W47ogGTKOuZbwzE5gBP+bW1cA ajN+XQEnQzm8lT9adLSuvsu2xwtnJGt/RPdr3QAy3Npxxi1sElzfWFnHDxR6pQysJoRz I7X6rSblhHfvUwQjY+Bvn/r55XQQ5QHC6lV6sADwkTh1w4GM/uGSbCgNlu69w1u4Pf6y fT3g==
X-Received by 10.28.48.213 with SMTP id w204mr3260293wmw.38.1449568284097; Tue, 08 Dec 2015 01:51:24 -0800 (PST)
X-Mailer git-send-email 2.6.2
Sender robomod@news.nic.it
List-ID <linux-kernel.vger.kernel.org>
X-Mailing-List linux-kernel@vger.kernel.org
Approved robomod@news.nic.it
Lines 78
Organization linux.* mail to news gateway
X-Original-Cc Roman Pen <r.peniaev@gmail.com>, Greg Kroah-Hartman <gregkh@linuxfoundation.org>, linux-kernel@vger.kernel.org
X-Original-Date Tue, 8 Dec 2015 10:51:03 +0100
X-Original-Message-ID <1449568266-17404-1-git-send-email-r.peniaev@gmail.com>
X-Original-Sender linux-kernel-owner@vger.kernel.org
Xref csiph.com linux.kernel:1286361

Show key headers only | View raw


Hello.

Here is an attempt to solve annoying race, which exists between two operations
on debugfs entries: write (setting a request) and read (reading a response).

E.g. let's assume that we have some storage device, which can have thousands
of snapshots (yeah, plenty of them, thus it is ridicoulous to create a debugfs
entry for each), and each snapshot is controlled by the handle, which is a UUID
or any non-numeric character sequence (for numeric sequence this problem can be
solved by 'seek' operation).  This device provides a debugfs entry 'snap_status',
which can be opened for reading and writing, where write - is an operation for
specifiying a request, and read - is an operation for getting a response back.

I.e. it is obvious, that to request a status of a snapshot you have to write a
UUID first of a snapshot and then read back a status response back, so the
sequence can be the following:

  # echo $UUID > /sys/kernel/debug/storage/snap_status
  # cat /sys/kernel/debug/storage/snap_status

Between those two operations a race exists, and if someone else comes and
requests status for another snapshot, the first requester will get incorrect
data.

An atomic request-set and response-read solution can be the following:

  # cat /sys/kernel/debug/storage/snap_status/$UUID

Here debugfs creates non-existent temporary entry on demand with the $UUID
name and eventually calls file operations, which were passed to the
'debugfs_create_dir_with_tmpfiles()' function.  Caller of that function can
control the correctness of the file name in 'i_fop->open' callback and can
return an error if temporary file name does not match some format.

Temporary file, which is created, will not appear in any lookups, further
linking is forbidden, corresponding dentry and inode will be freed when last
file descriptor is closed (see O_TMPFILE, with the only difference is that
debugfs temporary dentry has a name).

Of course this file creation on demand can be applied to many other cases,
where it is impossible to create as many debugfs entries as objects exist,
but atomicity of read-write can be required.

This atomicity can be achieved also by locking from userspace, but that approach
increases complexity and makes it hardly possible to invoke only few commands
from command line, like 'echo' or 'cat'.

So basically creating a temporary file on demand with a specified name is a
way to provide one additional parameter for an 'read' operation.

Probably, there is more elegant solution for that write-read race problem,
but I've not found any.

PS. I did not want to use configfs, because I have nothing to configure (what
    I have described is not a configuration issue), and I do not like to keep
	dentries in a system if userspace forgets to remove them.

Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-kernel@vger.kernel.org

Roman Pen (3):
  debugfs: make create directory logic more generic
  debugfs: implement 'debugfs_create_dir_with_tmpfiles()'
  debugfs: update some bits of documentation

 Documentation/filesystems/debugfs.txt |  25 ++++++
 fs/debugfs/inode.c                    | 157 ++++++++++++++++++++++++++++++----
 include/linux/debugfs.h               |  12 +++
 3 files changed, 179 insertions(+), 15 deletions(-)

-- 
2.6.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[RFC PATCH 0/3] debugfs: implement 'debugfs_create_dir_with_tmpfiles()' Roman Pen <r.peniaev@gmail.com> - 2015-12-08 11:00 +0100
  Re: [RFC PATCH 0/3] debugfs: implement  'debugfs_create_dir_with_tmpfiles()' Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-12-09 01:50 +0100
    Re: [RFC PATCH 0/3] debugfs: implement 'debugfs_create_dir_with_tmpfiles()' Roman Peniaev <r.peniaev@gmail.com> - 2015-12-09 21:10 +0100

csiph-web