Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1285303
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros |
| Date | 2015-12-07 14:40 +0100 |
| Message-ID | <qD4bf-52J-1@gated-at.bofh.it> (permalink) |
| References | <qD0r0-2GA-17@gated-at.bofh.it> <qD0AG-2K8-19@gated-at.bofh.it> <qD0AG-2K8-17@gated-at.bofh.it> <qD0Kl-2NJ-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
* Borislav Petkov <bp@alien8.de> wrote:
> On Mon, Dec 07, 2015 at 10:45:04AM +0100, Ingo Molnar wrote:
> >
> > * Borislav Petkov <bp@alien8.de> wrote:
> >
> > > static int __init chacha20_simd_mod_init(void)
> > > {
> > > - if (!cpu_has_ssse3)
> > > + if (!boot_cpu_has(X86_FEATURE_SSSE3))
> > > return -ENODEV;
> >
> > Btw., could we rename 'boot_cpu_has()' to the more appropriate (and shorter!)
> > 'system_has()' form?
> >
> > 'boot cpu' is a conceptual misnomer here really: it's just an implementational
> > detail that we are looking at the boot CPU's flags, what we really mean to express
> > is that these are system-wide features with no per-cpu properties.
> >
> > Agreed?
>
> Yeah, sounds good to me.
>
> Mind if I do it for the next part of the cleanup, though, and not rework
> those patches which are already tested?
Sure!
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/4] x86/cpufeature: Cleanup, p1 Borislav Petkov <bp@alien8.de> - 2015-12-07 10:40 +0100
[PATCH 1/4] x86/cpufeature: Move some of the scattered feature bits to x86_capability Borislav Petkov <bp@alien8.de> - 2015-12-07 10:50 +0100
[PATCH 4/4] x86/cpu: Provide a config option to disable static_cpu_has Borislav Petkov <bp@alien8.de> - 2015-12-07 10:50 +0100
[PATCH 2/4] x86/cpufeature: Cleanup get_cpu_cap() Borislav Petkov <bp@alien8.de> - 2015-12-07 10:50 +0100
Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Ingo Molnar <mingo@kernel.org> - 2015-12-07 10:50 +0100
Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Borislav Petkov <bp@alien8.de> - 2015-12-07 11:00 +0100
Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Ingo Molnar <mingo@kernel.org> - 2015-12-07 14:40 +0100
[PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Borislav Petkov <bp@alien8.de> - 2015-12-07 10:50 +0100
csiph-web