Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1282792

Re: [PATCH v2] Input: psmouse - rename ps2pp_init() to ps2pp_detect()

From Hans de Goede <hdegoede@redhat.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2] Input: psmouse - rename ps2pp_init() to ps2pp_detect()
Date 2015-12-03 09:40 +0100
Message-ID <qBxAK-2vK-23@gated-at.bofh.it> (permalink)
References <qBlge-31N-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

On 02-12-15 20:25, Dmitry Torokhov wrote:
> This makes Logitech PS2++ protocol implementation consistent with
> the naming in other protocols. Also mark the stub as "static inline"
>
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>

Much better / less confusing then the old code :)

Reviewed-by: Hans de Goede <hdegoede@redhat.com>

Regards,

hans



> ---
>
> V2: add forgotten drivers/input/mouse/logips2pp.c file.
>
>   drivers/input/mouse/logips2pp.c    | 2 +-
>   drivers/input/mouse/logips2pp.h    | 4 ++--
>   drivers/input/mouse/psmouse-base.c | 2 +-
>   3 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/input/mouse/logips2pp.c b/drivers/input/mouse/logips2pp.c
> index 136e222..422da1c 100644
> --- a/drivers/input/mouse/logips2pp.c
> +++ b/drivers/input/mouse/logips2pp.c
> @@ -325,7 +325,7 @@ static void ps2pp_set_model_properties(struct psmouse *psmouse,
>    * that support it.
>    */
>
> -int ps2pp_init(struct psmouse *psmouse, bool set_properties)
> +int ps2pp_detect(struct psmouse *psmouse, bool set_properties)
>   {
>   	struct ps2dev *ps2dev = &psmouse->ps2dev;
>   	unsigned char param[4];
> diff --git a/drivers/input/mouse/logips2pp.h b/drivers/input/mouse/logips2pp.h
> index 0c186f0..bf62945 100644
> --- a/drivers/input/mouse/logips2pp.h
> +++ b/drivers/input/mouse/logips2pp.h
> @@ -12,9 +12,9 @@
>   #define _LOGIPS2PP_H
>
>   #ifdef CONFIG_MOUSE_PS2_LOGIPS2PP
> -int ps2pp_init(struct psmouse *psmouse, bool set_properties);
> +int ps2pp_detect(struct psmouse *psmouse, bool set_properties);
>   #else
> -inline int ps2pp_init(struct psmouse *psmouse, bool set_properties)
> +static inline int ps2pp_detect(struct psmouse *psmouse, bool set_properties)
>   {
>   	return -ENOSYS;
>   }
> diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
> index e909c6e..90d9218 100644
> --- a/drivers/input/mouse/psmouse-base.c
> +++ b/drivers/input/mouse/psmouse-base.c
> @@ -699,7 +699,7 @@ static const struct psmouse_protocol psmouse_protocols[] = {
>   		.type		= PSMOUSE_PS2PP,
>   		.name		= "PS2++",
>   		.alias		= "logitech",
> -		.detect		= ps2pp_init,
> +		.detect		= ps2pp_detect,
>   	},
>   #endif
>   	{
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v2] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-02 20:30 +0100
  Re: [PATCH v2] Input: psmouse - rename ps2pp_init() to ps2pp_detect() Hans de Goede <hdegoede@redhat.com> - 2015-12-03 09:40 +0100

csiph-web